ANSYS Beginner Space Frame Demo (draft 3, 11/27/05)

Problem description

To verify that you understand the somewhat tricky input features of a space frame (general
beam bending, torsion, and axial load) it is wise to start with a published solution. An
example from [1] is a three member spatial “Z” shaped space frame that is fixed at both ends,
and loaded with a vertical point load at one of the two free nodes. That simple system is
illustrated in Figure 1. The top portion of the figure presents the desired orientations of the
(assumed) rectangular cross-section of each of the three members. The bottom portion
displays the usual line drawing representation used by most finite element systems for line
elements. The data to be given below were simply taken from reference [1].

The beam is assumed to have a rectangular cross-section. Thus, the only tricky part of the
study is to assure that the principle inertia axes of each rectangular beam section are
properly orientated in 3D space. The desired member placement is seen in the top of $
Figure while the usual line element format is in the bottom of that figure. The single line
format can let you overlook a beam orientation error and possibly lead to seriously incorrect
results.

Each beam has a local orthogonal coordinate system associated with it. The local x-axis
runs from the first node to the second. It is used to compute the local torsional inertia, IXX.
The local cross-section bending inertias, IYY and 1ZZ, are input relative to the local y- and z-
axes, respectively. This is not a problem when the beam has a circular cross-section since
IYY = |ZZ for any choice of the local z-axis. That is not true for non-circular sections, so the
local z-axis must be carefully established for each member (then the y-axis is computed by
the “right hand rule”). The local z-axis can be defined in two ways in ANSYS. Here the
method of using a third node will be employed. The three nodes define the local x-z plane,
and therefore the cross-sectional axis used by you to compute 1ZZ. Knowing that, the 1YY
value is calculated with respect to the remaining orthogonal cross-section axis.

When selecting candidates for use as the third node it is usually preferred to pick an existing
structure node. On some occasions you have to introduce a (full restrained) non-structural
node simply to use as a geometric reference point. ldeally you could find structural nodes
that make it easy to keep IYY and IZZ constant for a group of elements. Consider the first
member in this system. It happens to go from node 1 to node 2. Try to pick a third node
(from nodes 3, 4, or 5) that will allow the same 1YY and 1ZZ values to be used in other
elements. In Figure you can see that the plane formed by nodes 1-2-3 allow the first two
members to share the same maximum and minimum local inertia axes, but the use of
structural node 4 or geometry node 5 do not. Therefore, pick node 3 to define the local z-axis
for member 1, as seen in Figure . Similarly, in Figure , the second member, along line 2-3 Is
best, or more consistently, oriented by picking node 1 as its third node. For the last member,
you have to make a choice between keeping the same IYY and |ZZ values (i.e., same set of
real constants) by creating node 5 as a non-structural node, or picking structure node 2 and
reversing the 1YY and 1ZZ values. In other words, picking node 2, which is done here, will
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require a second set of real constants, and remembering when to activate that set. You will
be reminded of these choices when the actual data are input.
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Figure 1 A three member space frame with a vertical load
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Figure 4 Choice for second member local axis (plane 2-3-1)
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Start ANSYS

ANSYS is short for ANalysis SYStem. That pretty much sums up its capabilities.

Most areas of engineering calculation are included: stress, thermal, fluids, dynamics,
vibrations, frequency analysis, acoustics, electromagnetism, optimization, etc. are present
and usually have non-linear abilities as well. ANSYS was first released in 1971 and has
generally been one of the most popular finite element systems since then, worldwide. Since
it has a huge list of abilities its menu system can get relatively long. That is also true
because it (and all FEA systems at that time) was run in a “batch mode” on the largest
available computers. In other words, you could, and still can, execute ANSYS through an
input text file without using a Graphical User Interface (GUI). Once you are fully experienced
with the code that can be a real time saver. Every GUI session is saved in that format so that
you can simply edit it with a text editor and make small changes for a similar problem.

Begin ANSYS with Start->All Programs->ANSYS 10.0->ANSYS. That will bring you to the
main ANSYS Utility Menu as seen here in $.

%Y MSM Explorer
) Mozila Firefox

Bl ANSYS 10.0

All Pragrams I} ANSYS FLEXIm License Manager

A.NS\"S University Introductory Utility Menu

File Select Lisk  Plob  PlokCkels  WorkPlane  Parameters  Macro  MepuChrls  Help

Dizlao &sle|dH |

AMSYS Toolbar \]F'.NS‘.’S Command Prompt

sae_DB| REsUM_DB| quiT| powRGRPH|

AMSTS Main Menu @ |

1
HODES

Preferences
Preprocessor
Solution

General Postproc
TimeHist Postpro
Topological Opt
ROM Tool

Design Opt

Prob Design
Radiation Opt
Run-Time Stats
Session Editor
Finish

Figure 5 Opening ANSYS to the Utility Menu and graphics window
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Select job name and analysis type

The various menus below will sometimes get moved to a back (hidden) window. If you think

that has occurred hit the Raise Hidden button, gl You will always need a job name:
1. Utility Menu—>File=>Change Jobname.
2. Change_Jobname, type in the new name, OK (as seen $).

mANS‘rS University Introductory Utility Menu

File Select List Plok  PlokCerls  WorkPlane R
Clear 2 Skart Mew ... 7 | EI
Change Jobname ...

[ichonge Jobname
[/FILMAMY] Enker new jobnarme | SmithGriFFths_spaceframe § m

Figure 1 Setting the new job name

The ANSYS file sizes for real engineering problems get to be quite large, so have a directory
dedicated to ANSYS:

1. Utility Menu->File=>Change Directory.

2. Browse for Folder>Change Working Directory, pick your directory (ANSYS_dir in

Figure 2), OK.
Browse for Folder d |
Change Working Direckory
CDocuments and Settingsiakin iy DocurmentstaMsyYs_dic
E||E §E|Ett L|5t Ell:lt IF\NSI'I'IS dlr

Clear & Start New ... ﬂ

Change Jobname ...

Change Directaory ... e

Figure 2 Establish a directory for the analysis files

To keep up with your analysis studies over time create descriptive titles:
1. Utility Menu—>File=>Change Title.
2. Change Title, enter a descriptive title, OK (see Figure 3).

File Select Lisk  Plak

Clear & Stark Mew ...

Zhange Jobname ... mthange Title _' {

Change Directary ... [/TITLE] Enter new Eitle | Smikh Griffths space frame example 4.4b }

J T T T N T e Y S Ty

Figure 3 Provide a descriptive title

Page 5 of 26
Copyright J.E. Akin. All rights reserved.



Element type data

You will need a 3D structural line element, or frame member, that transmits axial forces, axial
torsion, and transverse bending moments. Open and add to element types you need:

Main Menu->Preferences>Preferences for GUI Filtering.

Check Structural, accept default h-Method, OK.

Main Menu—>Preprocesser>Element Type—>Add/Edit/Delete, as in Figure 4.

In Element Types, seen in Figure 5, pick Add->Library of Element Types.

Select (Structural) Beam and 3D elastic 4 (that is, beam4), OK.

In Element Types pick Close.

AMSYS Main Menu (&) ||
= PrEferences for GUI Filtering

FLEprOcessr [KEvW][JPMETH] Preferences For GUI Filtering
Solution

General Postproc Individual disciplinels) to show in the GUI

QahwN =

TimeHist Postpro
Topological Opt

Himrereee = =

ROM Tool [~ Thermal
Design Opt :

aMEYS Fluid
Prob Design L H
Radiation Opt [~ FLOTRAM CFD
Preferences

Element Types add..

= Preprocessor
B Element Type

Defined Element Tvpes:
NONE DEFIMED

Close |

Switch Elem Type

Figure 4 Declare the selection of a structural analysis

The Beam4 element is 3D and by default is used in the X,Y,Z space and usually requires
planning to orientate the local second area moment of inertia axes, 1YY and IZZ.

mLihrary of Element Types

only structural element bypes are shown

Library of Element Types Struckural Mass & | [3D Finike strain

Lirk. | 2rode 188
Beam 3node 159
Fipe ——
Solid plastic 24
Shell kapered 44

Solid-shell

Conskraink i

Element type reference number

Element Types

Defined Element Tvpes:
EBEAM4

Figure 5 Select space frame element type
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Element geometric properties data

Every element type requires one or more real constants, like area or moment of inertia, to
describe it. Here, you need several geometric items for each type of beam. You must enter
at least one: IYY (although giving just the area makes it a truss member, which can be a
useful trick sometimes). Paraphrasing from the ANSYS manual on the BEAM4 element:

“The geometry, node locations, and coordinate systems for this element are shown in
Figure 6]. The element is defined by two or three nodes, the cross-sectional area, two
area moments of inertia (1ZZ and 1YY), two thicknesses (TKY and TKZ), an angle of
orientation (©) about the element x-axis, the torsional moment of inertia (IXX), and the
material properties. ... If IXX is not specified or is equal to 0.0, it is assumed equal to
the polar moment of inertia (IYY+1ZZ). IXX should be positive and is usually less than
the polar moment of inertia. The element torsional stiffness decreases with decreasing
values of IXX. ... “

The element x-axis is oriented from node | toward node J. For the two-node option, the
default (©=0°) orientation of the element y-axis is automatically calculated to be
parallel to the global X-Y plane. Several orientations are shown in [Figure 6]. For the
case where the element is parallel to the global Z axis (or within a 0.01 percent slope
of it), the element y axis is oriented parallel to the global Y axis (as shown). For user
control of the element orientation about the element x-axis, use the © angle (THETA)
or the third node option. If both are defined, the third node option takes precedence.
The third node (K), if used, defines a plane (with | and J) containing the element x and
z axes (as shown).” [End paraphrasing.]

For circular sections 1YY = 1ZZ and you just need to locate the two end nodes to define the
local x-axis in space. Butin the common case where IYY and |ZZ are different you must
exercise care in using the third node to define the local z-axis. That is, the local x-z plane
coincides with the plane that contains the line (beam) element and the third (orientation)
node, K. The local IZZ is relative to that local z-axis and the 1YY is defined relative to the
local y-axis which is defined by the “right hand rule” from the local x- and z-axes. Experience
shows that this is the most common user error in employing 3D beam elements.

The selection of the third node occurs later, when the element connectivity is picked in the
graphics area, or read fro a file. Sometimes it is useful to have a few nodes just for
orientation use, if the needed structure nodes do not do that. If that approach is used they
should be completely restrained to avoid any potential problems in the equation solver.

To enter the various real constants to be referenced by the element types:

Main Menu->Preferences>Real Constants—> Add/Edit/Delete.

Real Constants> Add->Element Type for Real Constants.

Choose element type: Type 1 BEAM4, OK, as in Figure 7.

In Real Constant Set Number 1, for BEAMA4 verify Set No. 1.

Enter 4.0 (m"2) for Cross-sectional area (AREA); 1.0 (m*4) for IZZ, 0.3 (m”4) for
1YY, and 0.3 (m”4) for IXX (see Figure 8 left). The thicknesses (width and depth) of
the beam cross-section were not given in the problem statement. Thus, assume
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values of 0.4 (m) and 0.1 (m) in the z- and y-directions for TKZ and TKY, respectively,
to help illustrate a non-circular cross-section (like that in Figure 1), OK.

Set 1 appears in Real Constants. Select Add,

In Real Constant Set Number 2, for BEAMA4 verify Set No. 2.

Reverse the y- and z- values used in step 5. Enter 4.0 (m"2) for Cross-sectional area
(AREA); 1.0 (m?4) for IYY, 0.3 (m”4) for I1ZZ, and 0.3 (m”4) for IXX, 0.1 (m) for TKZ
and 0.4 (m) for TKY (see Figure 8 right), OK.

9. Set 2 appears in Real Constants. Select Close.
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Figure 6 Beam4 orientation data from ANSYS manual

Preferences

= Preprocessor
Element Type
E Real Constants

Real Constants

Defined Real Constant Sets

MOME DEFIMED

Elemenl: Type for Re.

Choose element type:

% Ok |
-l:_IrIFIE - 1 B E_.EM-':- _ i

Figure 7 Starting the first set of real constants
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Figure 8 Real constants for beams 1 and 2, and for beam 3, respectively

o e
=l =~

[

[} [ o
(=)
H . . PR

[

Note that there are 12 items for each real constants set. The same data can be entered through a text file, as
seen at the end of this example, but only 6 items are allowed on each of two lines of input.

One use of the attributes for the ThicKness in the Z (TKZ) and Y (TKY) directions is to plot the approximate
shape of each member in its local coordinate system, as seen in Figure . To create such a plot:

1. Utility Menu->PlotCtrls->Style->Size and Shape ...
2. Size and Shape—> Element SHAPE (ESHAPE) on. Shrink if desired (Figure 9).
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Figure 9 Displaying element shapes
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Define member material properties:

Here you will use the simplest linear, isotropic, 1D material description. ANSYS has full
anisotropic (completely directionally dependent), as well as non-linear material “constitutive
laws”. Activate the material properties with:

Main Menu->Preprocessor->Material Props—>Material Models.

Material Model Number 1 appears in Define Material Model Behavior.

Double click on Structural, then Linear, then Elastic, then Isotropic.

In Linear Isotropic Properties for Material Number 1 enter 1.e6 (kN/m”2) for elastic
modulus, EX, and 0.0 for Poisson’s ratio (PRXY), as in Figure 10, OK.

5. Close (X) the Define Material Model Behavior window.

hwn =

El Preprocessor mDEﬁnE Material Model Behavior

Element Type Material Edit Favorite Help
Real Constants

= Material Props — Material Models Defined — Material Madels Available
Material Librar
Temperature U‘Jlr'lil:s > W aterial Model Mumber 1 Favorites
Electromag Units @& structural
aterial Models @ Linear
Convert ALPx
et A AT b e Sl B e L Pl o o, st o P e Ao P e m A

Linear Isotropic Properties for Maker

Lingar Isokropic Material Properties For Material Number 1

T1
Temperatures _
Ex leG
|III.

PR&Y

=

Figure 10 Define the isotropic elastic properties

Define nodal data:

Of course, ANSYS has powerful mesh generation capabilities. However, for beginners or
small problems with only a few nodes you can type in the coordinates, or use cursor input via
the graphics window, or read them from a file. Use the first approach:
1. Main Menu->Preprocessor->Modeling->Create->Nodes->In Active CS.
2. In Create Nodes in Active Coordinate System of Figure 11 enter 1 for Node
number, X=0.,Y =5.,Z =5 (m), Apply, enter 2 for Node number, X=5.,Y=5.,Z=
5., Apply, enter 3 for Node number, X=5.,Y =5., Z=0., Apply, enter 4 for Node
number, X=5.,Y=0.,Z=0., Apply.
3. You can also add a non-structural node for beam orientation purposes. If so, enter 5
for Node number, X=5.,Y=0.,Z=5., Apply, OK.
4. If you make a mistake you can return and correct it in the above window, or delete
them all with Preprocessor->Modeling->Delete.
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Figure 11 Build the list of nodal coordinates

Now, plot the nodal values input (node 1 may be hidden behind the axis symbol):

1.
2.

3.
4.

Utility Menu—>PlotCtrls=>Numbering.

In Plot Numbering Controls check node numbers and select element numbers in
the pull down menu, OK.

Utility Menu—->PlotCtrls>Numbers and review the plot that is similar to Figure .

To get the reverse video white background of that figure use PlotCtrls>Style—>
Color->Reverse Video.

Define element attributes

Next you have to associate each of the elements with your previous material numbers and
real constant sets. Plan ahead and input those elements of the same type in sequence:

1.
2.

3.

o~

Main Menu—>Preprocessor>Modeling>Create>Elements>Elem Attributes.
In Element Attributes select defaults (type number = 1, material number = 1, real
constant set = 1), OK.

Main Menu->Preprocessor->Modeling->Create->Elements->

Auto numbered->Thru Nodes, as in Figure 13.

In Elements from nodes verify that Pick is checked on.

In the graphics window, seen in Figure 14, define the first element by picking node 1
(a square symbol appears) then node 2, then orientation node 3, OK, and the next
element number (1) appears in the graphics area.

Repeat this process for the last member sharing the current real constants set:
Thru Nodes, pick nodes 2, 3, and 1 for element 2 (bottom of Figure 14).
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Element Type
Real Constants
Material Props
Sections
E Modeling
E Create
Keypoinkts
Lines
Areas
Yolumes
Modes
B Elements

;

lem Attributes
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MElement Attributes

Define attributes for elements

[THPE] Element type number

[ sear ¢
: E
! E
g l;

[MaT] Material number

[RE&L] Real conskant sek number

[ES%S] Element coordinate sys

[SECHUM] Section number

[TsH&F] Target element shape

Straight line

Figure 12 Confirm the beam attributes for the first two members

B Preprocessor Elements from Node
Element Type
Real Constants * pick " Unpick
Material Props
Sections (¥ Zingle " Eox
B Modeling " Polygon (~ circle
E Create G
Keypoints
Lines — -
Areas
Yolumes Maximuam = Z0
Modes Minimum = 1
B Elements Hode No. =
Elem Attributes
B Auto Numbered PO et
Pl hru Nodes

Figure 13 Prepare to graphically pick the element connectivity

For the next (and last) element you need to change the number of its real constants data set
from 1 to 2. If those data were still correct but the next element was made of a different
material then a similar change would be required at this point. To accomplish the change,
seen in Figure 15, use:
1. Preprocessor->Modeling->Create->Elements->Elem Attributes.
2. In Element Attributes change the Real constants set number from 1 to 2.
If you are using text file input rather than the GUI then a similar change (REAL,2) is needed.

Now you can continue with picking the nodes for the final member in the mesh.
1. Repeat the previous connectivity definition process.
2. Thru Nodes, pick nodes 3, 4, and 2 for element 3, as illustrated in Figure 16.
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Figure 14 Define two elements for first real constants set
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Figure 15 Set new real constants set for next element(s)
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Figure 16 Final element pick for the space frame mesh

Check mesh data

It is wise to check such element input by plotting the nodes and elements, and/or the

element’s real constant set numbers via:
1. Utility Menu->PlotCtrls>Numbers ...

2. Plot Numbering Controls-> Elem /Attrib numbering pick real const num in Figure
17 (left) to create the associated display (right).

PIDI: Numbering Conkrols .
[fPHURM] Plat Mumbering Contrals
kP Keypoint numbers [~ off 4
LIME Line numbers [~ off |'
ARES Area numbers [~ off 1

i
WOLU Yolurne nurbers [~ oFf ]
NODE Mode numbers ¥ on [

Elem [ &ttrib numbering Real const num 4
I E

B A T T P S PSP SN SETCU PPt S N A S S NP S S SIS S S S SRR

S T S B Ty S ey

3
1 1
1
2
e
3 4

T Y S

smith Griffths space frame %

Figure 17 Displaying the real constant set numbers

Likewise, you can view a list of the data with:

1. Utility Menu->List->Elements->Nodes+Attr+RealConst.
2. When the ELIST (ELement LIST) window appears check those data and close it.
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Figure 18 Listing the element attributes for checking

Apply displacement restraints

The displacement restraints must be applied to reflect the physical support (often the most
unclear part of an analysis) as well as eliminating all the “rigid body motions” (RBM). Here
there are three translational RBM plus three rotational ones. Apply the system nodal
displacement restraints via:

1. Main Menu->Preprocessor>Loads—>Define Loads—>
Apply->Structural->Displacement->0On Nodes (see Figure 19).

2. In Apply U, Rot on Nodes verify that Pick and Single are checked on.

3. In the graphics window, Figure 20, select top node 1 and bottom node 4 (for complete
restraints), OK. After the panel changes form, highlight the fixed option for all of the
degrees of freedom components (All DOF) as the DOF to be constrained

4. Under Constant value enter 0, OK.

Note that these restraint operations are shown in the graphics window as triangles pointing in
the direction of restraint, at each restrained node. To list the current restraints:

1. Utility Menu->List>Loads>DOF Constraints>0n All Nodes.

2. When the (Displacement LIST) DLIST window appears check those data and close it
Review the graphical restraint symbols in Figure 20 to verify the choice you picked from the
list of available displacement restraints.
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B Structural " Polygen ~ gizcle
B Displacement " Loop
Z1 On Lines
Z1 On Areas Count

Z1 On Keypoints

PO Nodes

Z1 On Node Components

Maximuam

Minimum

Figure 19 Preparing to graphically assign displacement restraints

T «-..-..---..—w.-n....,-..,w:-m.]} m-ﬂpplr U,ROT on Nodes
I'_J[ s 1 4 [O] &pply Displacements (1,ROT) on Modes
2 :' Lab? DOFs bo be constrained
4 1
h
1
4
4
z‘ X 4
& ‘ Apply as

'ﬂ ' If Constant value then:

i
smith Griffths space frame "_ WALLIE Displacement walue

[ e ¢ T e S e e S e e e ey
31

1 1 "

1 |'-
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:
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g

!
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[

8]4 | . ) !
Smith Griffths space framei

¢ .

Figure 20 Picking nodes to restrain all displacements and rotations
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Apply nodal loads

This space frame is intended to carry a vertical load of -100 (kN) at node 2.

component force with:

1.

Specify that y-

Main Menu->Preprocessor->Loads—>Define

Loads>Apply->Structural->Force/Moment->0On Nodes.

2
3.

. In Apply F/M on Nodes verify that Pick and Single are on, and then pick node 2, OK.
When the window changes form (lower part of Figure 21, pick a vertical force (FY) for

the Direction of force and -100 (kN) for the Constant value, OK.

Then the arrows representing the load

Analysis Type
Fast Sol'n Opkn
B Define Loads
Settings
E Apply
B Structural
Displacement
El Force,/Moment
Z1 On Keypoints
A0 Nodes|
#71 0n Mode Components

W

should appear as in Figure 22.

Apply F/M on Nodes

{* pick - Tnpick

" Box

[ Single

- Polsygon
(7] Lioa

{" Circle

C ot

Maximam

e T N e N RS ST '-'U"'VW_I'-—-""—Y‘E‘-'-'-—"""«H
3

: i

; 1 L :
S

1

1

A X i

4, i

i

. . &
Smith Griffths space frame |

npply F/M on Nodes )

[F] aApply ForcefMoment on Modes

Lab  Direction of Forcefmom

If Constant value then:

VALUE Forcefmoment value

apply as Constant value

Figure 21 Graphically picking loaded nodes (lower left) and assigning values

Note that these load operations are shown in the graphics window as arrows pointing in the

direction of load, at each restrained node.

If your plot does not show everything you have

defined also try PlotCtrls->Symbols...»>Symbols and check that the items you want are

turned on.
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Smith Griffths space frame ¢

Figure 22 Loaded node's force arrow(s) appear

You may also wish to list the current loads:
1. Utility Menu->List->Loads->Forces=>0n All Nodes.
2. When the Force LIST (FLIST) window appears check those data and close it.

Saves and restarts

At this point you may want to save your data and restart the actual analysis later. If so:
1. Utility Menu->File->Save as Jobname.db.
2. Upon return open ANSYS and enter Utility Menu—=>File>Resume from... to get the
list of your ANSYS database (db) files so you can select the one you want.

Solve for displacements and secondary variables

To use the current (and only) load system (LS) enter:
1. Main Menu->Solution>Solve>Current LS, review the listed summary, OK.
2. When the solution of the simultaneous equations is complete you will be alerted that
the solution is done.

=
Preprocessor =
E Solution L
Analysis Type
[ Define Loads SOLUTION OPTIONS
Load Step Dpts PROBLEM DIMENSIONALITY. . . . . . . . . . . . . 3-D
DEGREES OF FREEDOM. . _ . . . ux uy Uz ROTX ROTY ROTZ

SE Management (I

Results Tracking i s T s

................. STATIC ¢(STEADY

From LS Files
Partial Solu
Manual Rezoning
Multi-field Set Up
ADAMS Connectiol

Diagnostics
Unabridged Menu

GLOBALLY ASSEMBLED MATRI® . . . . . . . . . . . SYMMETRIC
B Solve
s Solve Current Load Step X

LOAD STEP NUMBEF [SOLVE]Bedin Solution of Current Load Step

TIME AT END OF 1T
NUMEER OF SUBSTE
STEF CHANGE BOUM
PRINT OQUTPUT COb
DATABASE OQUTPUT

Review the summary information in the lister window {entitled "/STATLS
Command"), then press OK to start the solution,

i L U U e e o, P P o -~ -

Figure 23 Solving displacements for the current load set
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Solution is done!




Post-processing

Displacements

I
t is always wise to visually check the computed displacements:
1. Main Menu—>General Postproc>Plot Results>Deformed Shape.
2. In Plot Deformed Shape pick the combined deflected and undeformed option for
the Items to be plotted (KUND), OK. Check the plot in the graphics window, such as
the one seen in Figure 24.
3. Animate the computed deflections with:Utility Menu->PlotCrtls>Animate->
Deformed Shape.
4. Pick Def+undeformed in Animate Deformed Shape, OK.
5. If desired, employ the Animation Controller that appears, or simply pick Stop, Close.

Solution PIuI: Deformed Shape '

General Post
E ';'Z':l &";“zg]:ts [FLDISP] Plot Deformed Shape

Results Summary kUMD Items ko be plotked
Read Results

Failure Criteria

E Plot Results f+ Def + undeformed

Deformed Shape

[ Contgur Plot

" Def shape anly

(" Def + undef edge

T S R R S W e S e e T R S e e e T ey

1 3

S

‘h'--n.x

C NS e X T IR

4 3
Smith Griffths space frame Ex. 4.4b |

Figure 24 The deformed and undeformed space frame

To create a hardcopy (you may need to try various background colors):
1. Utility Menu->PlotCrtls>Hard Copy->Printer (or >File), select your printer name,
Print.
2. To get the reverse video white background of Figure 24 use PlotCtrls-> Style>
Color->Reverse Video.

Page 19 of 26
Copyright J.E. Akin. All rights reserved.



Since displacements and (infinitesimal) rotations are vector quantities it is wise to plot them in
that mode as a visual check of the response of the system. To do that:
1. General Postproc>Plot Results>Vector Plot>Predefined.
2. In Vector Plot of Predefined Vectors select DOF solution, Translation U, Vector
mode, and element nodes.
The resulting color plot will display the vectors with scaled lengths and with a color matching
the color bar scale, as seen in Figure 25.

\l'ectur Plot of Predefined ¥ectors

[FLMECT] Weckar Flat of Predefined Weckors

Solution

El General Postproc
Drata & File Opts
Results Summary

Ttem Weckor item to be plotted Translation U

Failure Criteria
E Plot Results
Deformed Shape
Contour Plot
= ¥Yector Plot
User-defined
Plot Path Item

Read Results Skress Raokation  ROT

Skrain-taokal
Skrain-mech-+thrm
Skrain-elastic
Skrain-thermal
Skrain-plastic
Skrain-creep

Translation U

Mode Yector or raster display

% ‘ector Mode

Concrete Plot
ThinFilm
List Results
Query Results
Options for Outp
Results Yiewer

{~ Raster Mode
Loc Vector location For resulks

{~ Elemn Centroid

{* Elem Modes

ﬂw_ﬁg\ﬂ!gﬂnﬂnﬂ B i I L N L o T B T I e T
R e e e i el e et
| 1 3
_.‘, |
4 2
5
L
r
‘

i \

!

: Ll X

; :
.__*

*

i

1 . 00404 .005287

5.0033 67 .004714 .00606

Figure 25 Nodal displacement vector plot

To see a (potentially long) list of displacement results:
1. Preferences->General Postproc->List Results>Nodal Solution.
2. In List Nodal Solution=>Nodal Solutions>DOF Solution->Displacement vector
sum, OK.
3. Examine the results in the PRNSOL (PRint Nodal SOLution) Command window of
Figure 26 and close it.
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4. Likewise, to see the nodal rotations, also in Figure 26,use List Nodal Solution->
Nodal Solutions=>DOF Solution>Rotation vector sum, OK.

& General Postproc FilList Nodal Solution
Data & File Opts _ i
Results Summary — Item to be listed
Read Results : ?
Failure Criteria FaaHkes 1
Plot Results & Madal Salution
El List Results g DOF Solution
Detailed Summary i H-Cormponent of displacement
Iteration Summry e s :
e EEd v-Component of displacemen
Sorted Listing i Z-Cormponent of displacement
odal Solution (7 Wi |:||E||:E'r|||-'r||' feckor sum
Y . . PP T L g 1 Iy e = T
Mo command
File {
| y
PRINT U NMODAL SOLUTIOM PER NODE l
|
s POST1 MODAL DEGREE OF FREEDOM LISTING s 41
LOAD STEP= 1 SUBSTEFP= 1 }
TIME= 1.8888 LOAD CASE= a i
THE FOLLOWING DEGREE OF FREEDOM RESULTS ARE IN THE GLOBAL COORDIMATE SYSTEM :
i
NODE Us uy Uz UsSuUH t
1 a.[8808 8.68880 868880 888680 4
2 —A_.3A370E-A5-A_59965E-82 A_87687VE-A3 A.606A3E-A2 f
3 B.95786E-A3-8.45359E-8A4 A.271129E-A3 A.13223E-A2 ;
4 a.[88n8 a.0880 a.0880 80880 J’
MAXTHUH FIBEOLUTE UALUES 1c.
MODE i
UALUE a. QE?BEE A3-8a. 59965E a2 a. 91129E A3 Aa. EBEBEE a2 E
e e et el et T e W et n i m gl e B e e B B, o B S e g e S an W e m e T S T RS A e, e it e, gl e a—\.ﬁ'\-..""—-nl‘-rl
P T e
: [
File: .
| 1
FRINT ROT HNODAL SOLUTION FPER NODE E
s POST1 NODAL DEGREE OF FREEDOM LISTING s 4
4
LOAD STEP= 1 SUBSTEP= 1
TIHE= 1.88868 LOAD CASE= a 14
THE FOLLOWING DEGREE OF FREEDOM RESULTS ARE IN THE GLOBAL COORDIMATE SYSTEM |‘
NODE ROTX ROTY ROTZ RSUH '|
1 a._888a a_a00a a._8Bee a.88aa 3
2 BA.11295E-A2-A.23600E-A3-0.15137E-82 A.19A33E-82 3
3 BA.74788E-A3-A_.15816E-A3-0_37269E-83 B_B4766E-A3 -
4 a.08a88 A.8880 8.698868 8.08a08 ii
MAXIMUM ABSOLUTE VALUES {
NODE 2 2 2 2 i
UALUE B.11295%E-82-0.23680E-83-A.1513VE-B2 B.19833E-82 4

Figure 26 Listing the nodal displacements and rotations
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Displacement solution validation

The generalized nodal displacements shown in Figure 26 agree with the (four significant
figure) results in [1]. Therefore, you can conclude that you have followed the correct steps for
the analysis of a space frame. Next you can review the system reactions, the member
reactions and member stresses.

System reaction forces

If the solver does not fail then your reactions will be equal and opposite of your resultant
forces and moments. Therefore they let you check the level of loads actually applied, versus
what you intended to apply. That is helpful especially for pressure loads. Check the system
reactions with:

1. Main Menu->General Postproc—>List Results>Reaction Solution.

2. In List Reaction Solution pick All items for Item to be listed, OK.

3. Review the Print Reaction SOLution (PRRSOL) Command window of Figure 27.

Those system reactions also agree with [1] to four significant figures.

E List Results
Detailed Summary
Iteration Summry
Percent Error
Sorted Listing
Modal Solution
Element Solution

Section Solution
superelem DOF mList Reaction Solution |
SpotWeld Solution [PRRSOL] List Reaction Solukion

% Lab Item to be listed

mPRRSDL Command
File

PRINT REACTION SOLUTIOMS PER NODE
=wxxx POST1 TOTAL REACTION SOLUTION LISTING sexcvess

L W R

;.

LOAD STEP= 1 SUBSTEP= 1 ¢
TIME= 1.PAAB LOAD CASE= @ .
THE FOLLOWING X.Y.Z SOLUTIONS ARE IN THE GLOBAL COORDINATE SYSTEM ;
NODE FX FY FZ M MYy MZ

1 2.4312 63.713 -27.539 —-67.769 116.85 250.10

4 -2.4312 36.287 27.539 24.A27 9.4899 80.616 |

TOTAL UALUES d
UALUE -@.19896E-13 160.00 -@.11369E-12 —43.742 125.54 330.72 ¢
"

B e AT L T B e, et e, i B e e e e, (S s e i e T e T e T e e, s T, ST T e S 2 o,

Figure 27 Examine the system reaction forces and moments

Page 22 of 26
Copyright J.E. Akin. All rights reserved.



Member end forces and moments

The element (member) end forces and moments, also known as the member reactions, in the
space frame resulting from the computed displacements can also be recovered and listed:
1. Main Menu->General Postproc>List Results2>Element Solution.
2. Get the member axial forces, in global components, from List Element
Solution>Element Solution>All Available Force Items, OK.
3. Review the PRESOL (PRint ELement SOLution) Command display of Figure 28.
Those element level reactions also agree with [1] to four significant figures.

mPRESDL Command i

File

PRINT FORC ELEMENT SOLUTION PER ELEMENT
s POST1 ELEMENT HODE TOTAL FORCE LISTING e

LOAD STEP= 1 SUBSTEP= 1
TIME= 1.686880 LOAD CASE= a

THE FOLLOWING Hif.z FORCES ARE IN GLOBAL COORDIMATES

e W

P . T

ELEM= 1 Fx FY FZ M MY MZ
1 -2.4312 —-63.713 27.537 67.7672 -116 .85 -2568.18 |
2 2.4312 63.713 —-27.537 —-67.769 —-21.646 —-68.461

ELEM= 2 FA FY FZ M MY MZ I
2 -2.4312 36 .287 27.537 67.7672 21.646 68.461
3 2.4312 —-36.287 —-27.537 113.67 —7.4899 —68.461 |

ELEM= 3 FA FY FZ Mi MY MZ ]
3 -2.4312 36 .287 27.537 -113.67 7.4897 68.461
4 2.4312 —-36.287 —-27.537 —24.827 —7.4899 —88.616 ¢

i o e B B e I AT e B e B S, e B e i, e e e e T It 2 St g g e e

Figure 28 Individual member end reactions

Member stress state

Reference [1] does not give the member stresses. ANSYS does give them and the strains
also. Here, the stress data, other than the neutral axis stress SDIR, are not meaningful
because the Y- and Z-thickness were not known but were chosen to allow visual checks, as
seen in Figure . When thickness values consistent with the area, IYY, and |ZZ are given then
the reported stresses are the bending stresses superimposed on the axial stresses.

TZ - JiMSBZT T? ,,.5 SR

(o

-_— SR —= ?-l— SBYB

5

Figure 29 Definition of the BEAM4 stresses
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B General Postproc
Data & File Opts
Results Summary
Read Results
Failure Criteria
Plot Results
B List Results

List Element Solution

Detailed Summary R :
Iteration Summry é
Percent Error Favorites ;
g &2 Element Salution )
Modal Solution :
= i =@ Stress -
lement Solution Lo, o ..«..._ A
= e e ST T ST AT T =
ﬁ Line Element Resulks

G

A it b, o e e, e, Rt R

et feam s

Figure 30 Selecting line element stress results

[i\PRESOL Command i

File

aa

PRINT ELEM ELEMENT SOLUTION PER ELEMENT
wxxxx POST1 ELEMENT SOLUTION LISTING sesesse

* S = Stress, DIR = DIRect (axial), BYT, BYB = Bending Y-axis Top, Bottom,

BZT, BZB = Bending Z-axis Top, Bottom

Figure 31 List of member local stresses*
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4
LOoAD STEP 1 SUBSTEP= 1 y
TIME= 1.884 LOAD CASE= A L
EL= 1 HNODES= 1 2 3 HMAT= 1 f
BEAM4 f
TEMFP = a.88 a.88 a.88 a.88 a.88 a.88 a.88 a.08 ?
LOCATION SDIR SBYT SBYE SBET SBZB ]
1 <I> -8.68788 —41 .684 41 .684 23.289 —23.289 1
2 <J> -B.68788 11.418 -11.418 —4.3292 4.3292 1
LOCATION SHMAH SHMIN ]
1 <I> 64 286 -65.5681 i
- -Mx?-—fi) 15 131‘\ _}-5*—-3'-42 e, Aymimham e, S bt e, T e e Pk g e e 'H
B Nt T et e T e T T e e T i 2 P Tm = i e e = m i e = ey
EL= 2 NODES— 2 3 1 MAT= 1 }
BEAM4 j
TEMP = a.8a8 a.aa8 a.88 a.88 a.aa a.98 a.aa8 a.88 i
LOCATION SDIR SBYT SBYB SBEZT SBZE b
1 (I -6 .8846 11.295 -11.295% -4_3292 4.3292
2 (J> -6 .8846 -18.944 18.944 -1.8788 1.8980 {
LOCATION SHAX SMIN 4
1 <I> 8.73793 —22.589 ;
2 <J> 13.9758 —27.727 i
Lo = e IR AL ot I Y T e o e ATOR L TR eimm it pqrzmla- S q:l:-:n:r-nnm,.h e, -ﬂ-n-rn: mn-na.-\..-n at?
EL= 3 HNODES= 3 4 2 HHT— 1 i
BEAM4 ]
TEMP = a. BB a.68a8 a.68a8 a.68a8 a.88 a.8a a.688 a.680 ;
LOCATION SDIR SBYT SBYB T SBZB i
1 (I> —2.8717 -13.6%92 13.692 —-18.944 18.944 !
2 I —7.8717 -16.123 16.123 4. 8044 —4 @844 4
LOCATION SHAk SHIN i
1 <I> 23.565 —41 788 1
44«3m(£ m11£56* = _fm_zgm---w-igg s et £ A e i i, o B v—-g



Exiting ANSYS

You can save the results to your data base, as described above, and close with File->EXxit.
To begin a different analysis, instead of picking Exit, use File>Clear & Start New ..., OK.

Closure

For this class of loading this three element model will be close to giving exact results for the
generalized nodal displacements. The beam deflections are cubic in space but most finite
element codes execute a linear plot between the two end nodes, as in Figure 24. If you
wanted to see the more realistic deformed shape the simplest thing to do is to divide each of
the elements into more elements, say 10 each. ANSYS can easily do that for you.

The job data for almost any analysis can be entered by a text file. The data for this example
are in Figure 32. One thing you should note about this alternate input approach is that the
data for the real constants sets will only accept six entries per line. Therefore, keyword r (for
real) must be followed with the keyword rmore in order to supply the IXX term here. Lines
beginning with a slash (/) are ANSYS commands. Comments are preceded with an
exclamation symbol (!) and extend to the end of the line.

To read such a data text file into ANSYS begin in the Utility Menu:

1. File->Read Input From ...
2. Pick the Directory, Filename, OK.

Then you can use the GUI to pick up your study at the stage where you chose to terminate
the batch text file. The entire analysis process can be controlled from a batch file.
Experienced users often find this feature to be a time saver.

Reference:

[.M. Smith, D.V. Griffiths, Programming the Finite Element Method, 3rd Ed, Chichester, John
Wiley, 1998
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FEFILHAM, S G SF 44
ftitle, Smith Griffths space frame Ex. 4.4h
fprep?
1 General Summary
Smith Griffth=s =pace frame Ex. 4.4b pagel3i7-141
Units: m, kN, m"2, m"4, KN/m"2
=4, IX=0.3, I¥ =1, IZ = 0.3, P = 100
ELASTIC = 1.e6, SHEAR = 1.e6

:

1
1
1
1
1
I #1 Fixed *3 Hode 2 di=splacements:
1
1
1
1
1
1

Y P P -3.039E-6 -5.997E-3 &.769E-4
iy : ! | Hode 2 rotations:
(1) r f2) [{3) 1.130E-3 -2.360E-4 -1.514E-3
\ orf | Hode 1 force reactions:
*3 | 2.431E4+0, 6.371E+1, -2.754E+1
#4 Fixed
n, 1, 0, 5, 51 begin node definition
n, 2, 5, 5, 5
n, 3, 5, 5, 0
n, 4, 5, o, o
et,1 beamd 1 first element type
mp.,ex,1,1eb 1 first material type

mp,prxy . 1,0.0

1 first real constant set {(elements 1 & 2}
1 ABREA, TZZ, IYY, TKZ, TKY, THETA {6 MAX 1)

r, 1, 4., 0.3, 1.0, 0.4, D.1, 0
1 ISTRH, IXX, SHEARZ, SHEARY, SPIH, DDMAS
rMOYe, 0, 0.6, o, o, o, o

1 gsecond real constant =set {(elements 3}
1 AREA, TIZZ, IYY, TKZ, TKY, THETA {6 MAX 1)

r, 2, 4.,1.0, 0.3, 0.1, 0.4, 0
1 ISTRH, IXX, SHEARZ, SHEARY, SPIH, ADDMAS
TMOYre , 0, 0.6, o, o, o, 1]

1 Define elements of et=1, mt=1. First 2 nodes set
1 local beam x-axis, third node set= local xz-plane

REAL .1 I turn on real property set #1
en, 1, 1, 2, 3 ! elem i, j, Kk

en, 2, 2, 3,1

REAL ,2 I activate real property set #2

d, 1, all, 0. I displacement restraints
d, 4, all, 0.
£, 2, £y, -100. I force at joint

finish ! batch input, go to GUI

Figure 32 Text file to describe this example mesh, restraints, and loads
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