11 Vibration Analysis

11.1 Introduction

A spring and a mass interact with one another to form a system that resonates at their characteristic natural
frequency. If energy is applied to a spring-mass system, it will vibrate at its natural frequency. The level of a
general vibration depends on the strength of the energy source as well as the damping inherent in the system.
Consider the single degree of freedom (DOF) system in Figure 11-1 that is usually introduced in a first course in
physics or ordinary differential equations. There, k is the spring constant, or stiffness, and m is the mass, and ¢
is a viscous damper. If the system is subjected to a horizontal force, say f(t), then Newton’s law of motion
leads to the differential equation of motion in terms of the displacement as a function of time, x(t):

m d’x /dt? + c dx / dt + k x(t) = f(t)

which requires the initial conditions on the displacement, x(0), and velocity, v(0) = dx / dt(0). When there is no
external force and no damping, then it is called free, undamped motion, or simple harmonic motion (SHM):

m d’x /dt’ + k x(t) = 0.

The usual simple harmonic motion assumption is x(t) = a sin (wt) where a is the amplitude of motion and w is
the circular frequency of the motion. Then the motion is described by

[k —w? m] a sin (wt) =0, or [k —w’ m] = 0.

The above equation represents the simplest eigen-analysis problem. There you wish to solve for the
eigenvalue, w, and the eigenvector, a. Note that the amplitude, g, of the eigenvector is not known. It is
common to scale the eigenvector to make the largest amplitude unity. The above scalar problem is easily
solved for the circular frequency (eigenvalue),

w = 2nF, =+k/m,

which is related to the so called natural frequency, F,, by F, = w / 2m.
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Figure 11-1 A spring-mass-damper single degree of freedom system

From this, it is seen that if the stiffness increases, the natural frequency also increases, and if the mass
increases, the natural frequency decreases. If the system has damping, which all physical systems do, its
frequency of response is a little lower, and depends on the amount of damping. Numerous tabulated solutions
for natural frequencies and mode shape can be found in [3]. They can be useful in validating finite element
calculations.

Note that the above simplification neglected the mass of both the spring and the dampener. Any physical
structure vibration can be modeled by springs (stiffnesses), masses, and dampers. In elementary models you
use line springs and dampers, and point masses. It is typical to refer to such a system as a “lumped mass
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system”. For a continuous part, both its stiffness and mass are associated with the same volume. In other
words, a given volume is going to have a strain energy associated with its stiffness and a kinetic energy
associated with its mass. A continuous part has mass and stiffness matrices that are of the same size (have the
same number of DOF). The mass contributions therefore interact and can not naturally be lumped to a single
value at a point. There are numerical algorithms to accomplish such a lumped (or diagonal) mass matrix but it
does not arise in the consistent finite element formulation.

11.2 Finite element vibration studies

In finite element models, the continuous nature of the stiffness and mass leads to the use of square matrices
for stiffness, mass, and damping. They can still contain special cases of line element springs and dampers, as
well as point masses. Dampers dissipate energy, but springs and masses do not.

If you have a finite element system with many DOF then the above single DOF system generalizes to a
displacement vector, X(t) interacting with a square mass matrix, M, stiffness matrix, K, damping matrix C, and
externally applied force vector, F(t), but retains the same general form:

M d°X / dt? + CdX / dt + K X(t) = F(t)

plus the initial conditions on the displacement, X(0), and velocity, v(0) = dX / dt(0). Integrating these equations
in time gives a time history solution. The solution concepts are basically the same, they just have to be done
using matrix algebra. The corresponding SHM, or free vibration mode (C = 0, F = 0) for a finite element system
is

M d?X / dt? + K X(t) = 0.

The SHM assumption generalizes to X(t) = A sin (wt) where the amplitude, A, is usually called the mode shape
vector at circular frequency w. This leads to the general matrix eigenvalue problem

|K-w’M|[=0.

There is a frequency, say wy, and mode shape vector, Ay, for each degree of freedom, k. A matrix eigenvalue-
eigenvector solution is much more computationally expensive that a matrix time history solution. Therefore
most finite element systems usually solve for the first few natural frequencies. Depending on the available
computer power, that may mean 10 to 100 frequencies. SW Simulation includes natural frequency and mode
shape calculations as well as time history solutions.

Usually you are interested only in the first few natural frequencies. In SW Simulation, the default number of
frequencies to be determined is five (that number is controlled via Study—=> Properties=>Options=> Number of
frequencies). A zero natural (or slightly negative one) frequency corresponds to a rigid body motion. A part or
assembly has at most six RBM of ‘vibration’, depending on how or if it is supported. If a shell model is used the
rotational DOF exist and the mass matrix is generalized to include the mass moments of inertia. For every
natural frequency there is a corresponding vibration mode shape. Most mode shapes can generally be
described as being an axial mode, torsional mode, bending mode, or general mode

Like stress analysis models, probably the most challenging part of getting accurate finite element natural
frequencies and mode shapes is to get the type and locations of the restraints correct. A crude mesh will give
accurate frequency values, but not accurate stress values. The TK Solver case solver software contains
equations for most known analytic solutions for the frequencies of mechanical systems. They can be quite
useful in validating the finite element frequency results.

In section 3.3, the stiffness matrix for a linear axial bar was given. It is repeated here along with its consistent
mass matrix:

[k] = % [_1 _ﬂ ,[m] = %[i 12], m = pAL.

Draft 5.4 Copyright 2009. All rights reserved. 180



FEA Concepts: SW Simulation Overview J.E. Akin

If you utilize a quadratic (three node) line element the corresponding element matrices are

7 -8 1 m 4 2 -1
-8 16 -8|, [ml=—(2 16 2|

k] =2
30
1 -8 7 -1 2 4

T 3L

11.3 Analytic solutions for frequencies

The analytic frequency and mode shape solutions for many common geometries are found In a course on the
vibration of continuous media. The geometries include axial bars, axial shafts in torsion, beams with
transverse motion vibration, flat plates of various shapes, and thin shells of various shapes. Several examples
of them are given in the “validation problems” set of examples presented along side the software tutorials. of

Consider the longitudinal vibration of a bar. The results depend on which type of support is applied to each
end of the bar. For one end restrained and the other end free the natural frequencies are

2n-1)mc E
wn=;,c: - n=1,2,3,..00,
2L p

However, if both ends are restrained they are

nrmc E
Wn =T,c:\/%, n=1,2,3, .. 00,

This shows that for a continuous body there are, in theory, an infinite number of natural frequencies and mode
shapes. Try a single quadratic element to model a fixed-fixed bar frequency. Restrain the two end DOF (the
first and third row and column) of the above 3 by 3 matrices. Only a single DOF remains to approximate the
first mode. Solve the restrained matrix eigen-problem: [k] — w?[m]| = 0. The reduced terms in the matrices
are

EA pAL
—[16] — w?>—=—=[16] =0
3L [16] — w 30 [16]
sow? = 108 and w; = 10< = 3.16 = which is less that 1% error compared to the exact result. Adding more
17 12p L L

elements increases the accuracy of each frequency estimate, and also yields estimates of the frequencies
associated with the additional DOF. For example, adding a second quadratic bar element gives a total of three
un-restrained DOF. So you could solve for the first three frequencies. The value for w; would be more
accurate and you would have the first estimates of w,and w;.

Usually, the masses farthest from the supports have the most effects on the natural frequency calculations. If
you only care about the frequencies you could use split lines to build larger elements near the supports. For
beams and shells, the transverse displacements are more important than the tangential rotational DOF.

11.4 Frequencies of a curved solid

To illustrate a typical natural frequency problem consider a brass, 75 degree segment of an annulus solid
having a thickness of 0.3 m, an average radius of 1.5 m, and a width of I m. The component is encastred
(fixed) at one rectangular face. The thickness to width ratio is 0.3. That suggests that the study should be
conducted with either a solid model or a thick shell model. Both types of elements will be used to indicate the
range of uncertainty.

There is no simple analytic estimate to validate the study of a thick curved body. However, there is a simple
cantilever beam frequency estimate that can give an estimate of the frequencies. The first frequency of such a
thin beam is
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Eh?

B _ 1.732
4 12pL*

= 1.732
@1 pAL

Here, the effect length, L, must be estimated. If you take the outer arc length as that length, the estimate is
w, = 48.4 Hz. Using the centerline arc gives 92.3 Hz.

Generally, the displacement degrees of freedom are more important in getting natural frequencies and mode
shapes than are rotational DOF. Therefore, the solid study is probably best here. In vibration problems, the
material located farthest from the supports are more important. You should use mesh control to create small
elements in such regions. The modeling process is:

1. Sketch and dimension the area. Extrude it to a thickness of 0.3 m.

0
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2. Click on a curved face, Insert Sketch.
3. Addaline and arc near the free edges farthest from the support, for later mesh control.

4. Insert->Curve->Split Line

11.4.1 SW Simulation frequency studies

11.4.1.1 SW Simulation Manager
Selecting the SW Simulation Manager (CWManager) icon:

4. Right click on the top name to access Study which opens the Study panel.
5. Assign a Study name, choose Frequency for the Analysis type.
6. Define the Mesh type to be solid, click OK.

11.4.1.2 Define the material

At this point Solids will appear in the CWManager menu:

1. Rightclick on it to apply material data. The component is to be made of brass.
2. Pick Apply Material to All-> Material panel->From library files button—-> Copper Alloys and select
brass, set the Units to MKS.
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Description I
Froperty |Description “alue |Units
Ex Elastic modulus 1121687 834 kgf/cm™2
ML FPoizzon's ratio Tl
Gy Shear modulus kof/om”2
DENS bMass density kofom™3

11.4.1.3 Meshing
Specify a finer mesh away from the support, and a crude mesh near the support:

1. Mesh->Mesh Control, select small outer faces, set size to 0.06 m.

| Mesh control |
V) %) 2)
Selected entities ()

NE

¥ Show preview
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& Lse same element
size
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& Jooe  x|m 7]
% |15 i
4 |3 :I
2. Mesh>Mesh Control, select other faces, set size to 0.3 m.
3. Mesh—->Create Mesh
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11.4.1.4 Restrain the system

4. Select Fixtures=>Immovable and pick the support rectangles. Click OK. Run.

V) X2

2

Type
|Imm0vable (No transj

E[ﬂ I| Face<1>

11.4.1.5 Post-process the frequencies and mode shapes

The Run->Properties were set to compute five modes and frequencies, but only the first three are
summarized here. Select Results and display each mode in turn. Change views for better understanding as in
Figure 11-2. Mode one is like that of a cantilever beam, with the outer edge moving perpendicular to the
original plane. Mode two is a vibration in the original plane. Mode three seems to be mainly a twisting
vibration. The frequencies are shown in the figure text. You can also have SW Simulation list them. The first
three modes are also given in Table 11-1, along with the corresponding values from a thick shell model
presented below. There is about a 10% difference in the computed frequencies.
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Figure 11-2 First three solid studies modes and frequencies

Table 11-1 Natural frequencies (Hz) from solids and thick shells
Model Model | Mode2 | Mode 3
Solid 52 142 169
Thick shell | 46 126 155
Thin beam | 48.4 - -

11.4.2 Thick shell version

The above study was repeated with a thick shell and the same mesh controls. Some results are in Figure 11-3
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Figure 11-3 First two thick shell frequencies

11.5 Influencing the natural frequency

If you wish to influence the natural frequency you can automate the process by employing the SW Simulation
optimization ability to vary the part geometric design parameters. You can also get a feel for the controlling
factors by noting the fact that the natural frequencies (in Hz) of plates can generally be expressed as

_ N Eh3 1/2
fj = 21 L2 [12p(1—v2)]

where f; is the natural frequency in cycles per second, E is the elastic modulus, v is Poisson’s ratio, p is the

mass density, h is the (thin) plate thickness, L is a characteristic length of the plate. The remaining factor, ;, is
dependent on the support conditions and geometric shape of the plate. It is often a tabulated feature in
standard handbooks like [3, 11]. Usually, the thickness and length are the easiest features to change. The
quantity in square brackets reduces to [E I/p] for a straight beam.
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