Mesh Control in CosmosWorks (Draft 4. 10/7/06)

Introduction

One must plan ahead when building a solid model so that it can be used for realistic finite element load and/or restraint analysis cases. You often do that in the solid modeling phase by using lines or arcs to partition lines, curves, or surfaces. This is called using a “split line” in SolidWorks and CosmosWorks. There is also a “split part” feature that is similar except that it cuts a part into multiple sub-parts. You sometimes need to do that for symmetry or anti-symmetry finite element analysis so that we can analyze the part more efficiently.

Initial analysis

The split line concepts for mesh control will be illustrated via the first tutorial “Static Analysis of a Part”, using the example file Tutor1.sldprt which is shown in Figure 1. (Remember to save it with a new name.) Consider that tutorial to be a preliminary analysis. You should recall that there was bending of the base plate near the loaded vertical post. However, the original solid mesh had only one element through the thickness in that region and would therefore underestimate the bending stresses there. You need to control the mesh there to form 5 to 6 layers to accurately capture the change in bending stress through the thickness.

![Figure 1 Original part, restraints, load, and mesh](image)

The original deformed shape, in Figure 2, is shown relative to the undeformed part (in gray). You see bending at the end of the base and deflection of the part bottom back edge in the direction of the (unseen) supporting object below it. From the original effective stress plot in Figure 3 and Figure 4 you can see that large regions, within the red contours, have exceeded the material yield stress. Actually, the maximum value is over 133,000 psi, or about 1.5 times the yield stress, on the top and bottom of the base. Clearly, this part must have its material or dimensions changed and/or new support options must be utilized.
Begin by reconsidering the restraints utilized. In many problems the restraints are unclear or questionable and you need to consider other restraint cases. You previously restrained all the three translations on the two small cylindrical surfaces. That makes those surfaces perfectly rigid. That would be almost impossible to build. It is likely that the holes were intended to be bolt holes. Then the applied backward (-z) pressure load would probably require the development of tension reaction forces along the back (-z) half of the bolt cylinder. That would not happen because an air gap would open up. Also, a bolt usually applies a restraint to the surface under the bolt head (in addition to a bolt bearing load on its cylindrical part), and that is not in the original choice of restraints. Furthermore, the bracket seems to be attached to some rigid object under it and therefore you would expect the back edge of the bracket to be somehow supported by that object when that region of the part deforms as seen in Figure 2.
As a new possible restraint set, assume that the bolt heads are tight and act on a small surface ring around each hold. That could provide rigid body translation restraints in 3 directions. Each bolt would prevent three translations and the pair of them combines to also prevent three rigid body rotations. Thus they combine to prevent all six possible rigid body motions (RBM). If the bolts were not tight then only a normal displacement (along the bolt axis) would be restrained on the base top surface (and two RBM would remain to be addressed).

Bearing loads on the bolt shaft can be found by an iterative process in CosmosWorks, but for early studies you can assume a small cylindrical contact at the most positive $z$ (front) location. The previously computed bending of the part is also assumed to cause contact with the supporting object below, and thus a $y$-translational restraint, along the bottom back edge of the part.

To accomplish those types of restraint controls you need to “split” the surfaces and transition the mesh in those regions to get better results. Thus, you need to form two smaller surface rings for the bolt heads, and split the cylinders into smaller bearing areas.

**Splitting a Surface or Curve**

To avoid changing the master tutorial file, open the part and then “save as” a new file name on the desktop. To introduce the required split lines:

1. Select the top surface of the base by moving the cursor over it until its boundary turns green and **Insert Sketch**.
2. Pick the **Sketch** icon and pick the **Circle** option so we can form a bolt head washer area.
3. Place the cursor on the top hole edge to “wake up” the center point. Then draw a larger circle on the surface. Set its diameter to 30 mm and hit **OK** (Figure 5). That does not change the surface; it just adds a circle to it.
4. To split the surface go to the top menu bar and select **Insert ➔ Curve ➔ Split Line**. The **Type** will be a projection (Figure 6).

5. Next, pick the surface(s) to be cut by this curve. Here it will be the top of the base plate again so select it and enter **OK**.

6. Repeat the above two processes for the second hole.

![Figure 5 Constructing the first circle to split the surface](image)

![Figure 6 Selecting the first circular split line](image)

Now you will see that moving the cursor around shows a new circle and a new ring of surface area that could be used to enforce restraints or loads. The new surface areas are shown in Figure 7. Later you will use these newly created ring areas as a bolt head (washer) restraint region.

To form a vertical bearing region on the bolt hole sidewall:

1. Select the top surface and use **Sketch ➔ Line**. “Wake up” the center point again. Use it to draw a straight line forward from the center that crosses the circle.
2. Convert it to a construction line and at two other radial lines offset by about 25°.
3. Select **Insert ➔ Curve ➔ Split Line** and pick the cylinder of the first bolt hole, **OK**. That creates a new load bearing surface (Figure 8) that could be restrained and/or control the mesh.
4. Repeat those operations for the second bolt hole.
The above surface splits were constructed to give more flexibility in applying various
displacement restraints. You will need another surface split to help exercise engineering
control over the revised mesh. You want the “L” shaped side area to have the leg split off
so you can control a bending mesh there:

1. Select the (+x) right side face. Right click on the surface, **Insert Sketch** → Sketch → Line.

2. “Wake up” the left vertical line and use it to put in a short vertical line that crosses
   the bottom of the base.

3. Use **Insert** → **Curve** → **Split Line** and select the “L” face, OK.

Now you see it has become two rectangles (Figure 9). You can control the number of
layers in the smaller one to account for local bending.

---

**Figure 7** The original surface is now three surfaces

**Figure 8** Creating a bolt bearing surface

**Figure 9** Splitting the side wall area to introduce a bending control mesh
All of these new surface areas and lines can have different local mesh sizes prescribed to control our mesh generation. That is a standard feature of CosmosWorks, but you must supply the engineering judgment as to where any part needs the extra line or surface divisions for applying loads (or heat sources) and restraints in an analysis. True point loads or point moments are unusual in practice. They should be replaced by reasonable loading areas (that require split curves) and pressure distributions.

**Beginning CosmosWorks study**

Activate the CosmosWorks Manager by clicking on its icon (4th from the left). Then start a static, solid part study, and pick alloy steel as the part material, as summarized in Figure 10. Note that the yield stress is about 90,000 psi.

![Study](image)

![Material](image)

**Mesh Control**

Wherever translational displacement restraints are applied, reaction forces are developed and localized stress concentrations are likely. Therefore, you want to assure that small elements are created in such regions. This process is referred to as mesh control. It is required in almost every study. Invoke it with:

1. Right click on **Mesh ➔ Apply Control** to bring up the **Mesh Control panel**. The default element size of about 3 mm needs to be changed in the new regions created above. Select the region around the two bolt washers by picking those two surfaces, in Figure 11, and setting the desired size to 1mm.

2. Likewise, for the two bearing surfaces within the smaller vertical cylindrical holes set the size to about 1.5 mm.
In the final region (Figure 12) you need several elements through the thickness of curved front corner to accurately model the local bending seen in the first study. Select the small split rectangle and the adjacent cylindrical corner and use an element size of about 1.5 mm.

![Mesh Control](image)

**Figure 11  Controlling elements under the bolt washer split surfaces**

*Mesh preview*

Use **Mesh → Create** to generate the mesh. Then examine it and increase or decrease the local sizes specified above so that it looks acceptable, as shown in Figure 13. Note that the mesh makes a smooth transition from the smaller element sizes to the larger default size in the far body regions. An additional refinement near the corner of the base and rectangular shaped leg (below the loaded tube) would also be wise. You should always preview the mesh before running the solution.

*Restraints*

The new restraints will be enforced by beginning with the new surface areas representing the bolt washer contact regions:

1. Select **Loads/Restraints → Restraints** and restrain the washer areas against all three translation directions (solid elements do not have rotational dof).
2. In the **Restraint panel** pick the two concentric ring faces as the **Selected Entities** and chose **immovable** as the **Type** (top right in Figure 14). That will prevent all six possible rigid body motions (RBM) that can occur with a solid part.
3. Next select the two cylindrical bolt bearing faces and **restrain radial motion** on the cylindrical face **Type**, as shown in the lower left of Figure 14 (That prevents z translational RBM and the y rotational RBM.)

4. Finally, this study will assume the bottom back edge helps support the part. Select that back edge line and choose the **reference plane Type**. Restrain the edge line
displacement, relative to the front face, by picking the vertical direction (parallel to the front plane) and preview the restraint arrow to verify the correct choice seen in the lower right of Figure 14. (That prevents RBM in \( y \) translation and \( z \) rotation.)

Figure 14  The new part displacement restraint choices

**Pressure loading**

This part has one pressure loading on the large front tube face. Impose it with:

1. **Loads/Restraints→Pressure.** In the **Pressure panel** give the **Pressure Type** as normal to the face, set the units and value (1,000 psi) and preview the arrows to verify the direction (sign of the pressure), as illustrated in Figure 15. Clearly, the resultant applied force will be that pressure times the selected surface area. Since SolidWorks is a parametric modeler remember that if you change either diameter of the tube the area and the resultant force will also change.

2. If you mean to specify the total force then use **Loads/Restraints→Force** and give the total force on that area. It would not change with a parametric area change.
To check the total force (after the displacement solution phase) you can check the reaction force since it must be equal and opposite. You can do that in post-processing by right clicking on the Displacement report → Reactions.

Figure 15  Applying the constant pressure loading

**Run the study**

Right click on the study name and select Run.

**Post-processing**

**Displacement results**

The displacements are shown amplified in Figure 16 along with the gray undeformed part. As with the first approximation, the main bending region is the rounded front corner of the base plate. The mesh there is now fine enough to describe the flexural stress and shear stress as they change through the thickness. The default contour plot style for viewing the displacements is a continuous color variation. These are pretty and should be used at some point in a written stress analysis report, but they tend to hide some useful engineering checks. To create a more informative displacement vector plot:

1. Right click in the graphics area. Then pick Edit Definition → Vector → Line → OK. When the displacement vector plot appears use Vector Plot Options to dynamically control the arrows for maximum clarity.
2. Rotate this view (hold down the center mouse button and move the mouse) to find the most informative orientation. That is probably the right side view seen in the top of Figure 16.

3. Next, convert to a discrete contour display of the magnitude of the displacement vector (bottom of Figure 16). It is more difficult to interpret than vector plots.

![Figure 16 Amplified part displacements](image)

**Effective stress**

The effective stress distribution on the top of the base is shown in Figure 17. There are two different contour options are illustrated. The line contour form tend to be more useful if preliminary reports are being prepared on black and white printers. The material yield stress was 90,000 psi, so every region colored in red is above yield. In that figure the **Edit Definition** feature was used to manually specify the stress range and the number of discrete colors.
Rotating the part shows that there are other regions of the part above the yield stress. On the bottom corner of the base the assumed line support has also caused high local stresses, as seen in Figure 18. In that figure you should also note that the bottom edge of one bolt bearing surface shows a small region of yielding. That should be examined in more detail and other views.

Line or point restraints are not likely to exist in real part components. You could revise that region by putting in a split line to create a narrow triangular support area. That would be more accurate, if the resulting part stresses there are compressive. Otherwise, you would need to use a contact surface. Using contact surfaces where gaps can develop requires a much more time consuming iterative solution. However, the important thing is to attempt an accurate model of the part response, not an easy model.

![Figure 17 Failure criterion on the base top surface](image-url)
**Maximum Principal Stress**

The extreme values of the stress tensor at any point are known as the principle stresses (eigenvalues of the stress tensor). For 3D parts here are three normal principle stresses and a maximum shear stress. The principle normal stress components have both a magnitude and direction. They can be represented as directed line segments with two end arrow heads used to indicate tension or compression. The maximum principal stress vector plot, in Figure 19, shows the highest tension stress (and is a failure criterion for some materials). Here, it occurs in the yielding region where the base joins the vertical tube support. Those high stress concentrations could (and should) be reduced by adding fillets along the associated edges along the re-entrant corners.
Closure

The main goal of this study was to illustrate the usefulness of split surfaces, and the need for engineering judgment in making restraint assumptions. The locations and type of restraints are usually the least well know aspect of a part analysis or design. Load conditions are probably the next least reliable information. Use friendly software to investigate various combinations of loads and restraints to get the safest results.