Introduction

This example will look at essentially planar objects subjected to centrifugal loads. That is, loads due to angular velocity and/or angular acceleration about an axis. The part under consideration is a spinning grid strainer that rotates about a center axis perpendicular to its plane. The part has five symmetrical segments, of 72 degrees each, and each segment has a set of slots that have mirror symmetry about a plane at 36 degrees. The questions are: 1. Does a cyclic symmetric part, with respect to its spin axis, have a corresponding set of cyclic displacements and stresses when subject to an angular velocity, $\omega$, about that axis? 2. Does it have the same type of behavior when subjected to an angular acceleration, $\alpha$, about that axis?

To answer these questions you need to recall the acceleration kinematics of a point mass, $dm = \rho \, dV$, following a circular path of radius $r$. In the radial direction there are usually two terms, $r \, \omega^2$ that always acts toward the center and $\frac{dr}{dt^2}$ acting in the direction of change of the radial velocity. The latter term is zero when $r$ is constant, as on a rigid body. In the tangential direction there are also two components in general: $r \, \alpha$ acting in the direction of $\alpha$ and a Coriolis term of $2 \, \frac{dr}{dt} \, \omega$, in the direction of $\omega$ if $\frac{dr}{dt}$ is positive. Again the latter term is zero for a rigid body. The remaining radial acceleration ($r \, \omega^2$) always acts through the axis of rotation (as a purely radial load), thus, it will have full cyclic symmetry. Angular acceleration always acts in the tangential direction a rotating part, as it spins up or spins down. Then, the part is basically subjected to torsional like loading about its axis of rotation. To illustrate these concepts consider a cantilever beam rotating about an axis outside its left end, as shown in Figure 1 and Figure 2.
For angular acceleration only, the body force load is transverse to the beam and increases with the distance from the left end (Figure 1). By way of comparison, for angular velocity only, the body force load is radial (nearly axial), and increases with distance from the axis of revolution. Therefore, it has a non-uniform elongation in the radial direction (Figure 2). For angular velocity loading only you can begin with the simplest symmetric segment.

**Building a segment geometry**

The desired rotating spin grid is shown in Figure 3. The part has a inner shaft hole diameter, and outermost diameter of 1 inch and 4 inches, respectively. It has six curved slots ¼ inch wide, symmetric about the 36 degree line, and end in a semi-circular arc that is 1/8 inch from the 0 degree line. It is 0.20 inches thick.

Prepare a sketch in the top view with several radial and arc construction lines via:

1. **FrontÆInsert Sketch**, as outlined in Figure 4 and Figure 5.
2. Extrude, about the mid-plane, to the specified thickness (Figure 5).
3. Define the axis about which the part will rotate. In this case it’s the axis of the inner circular hole. Use **InsertÆReference GeometryÆAxis** to open the **Axis panel** (see Figure 6)
4. In the **Axis panel** check **Cylindrical/Conical Face** and select the inner-most cylindrical surface segment of the part and **Axis 1** will be defined as a reference geometry entity (Figure 7).
Figure 5  Adding the curved slots, and extruding the thickness

Figure 6  Preparing an axis of rotation

Figure 7  Picking the actual axis of rotation
At this point the smallest geometrical region is complete and you can move on the **CosmosWorks Feature Manager** (CWManager) to conduct the deflection and stress analysis.

**Initial CosmosWorks angular velocity model**

**Analysis type and material choice**

To open a centrifugal analysis you have to decide if it is classified as static, vibration, or something else. Instead of applying Newton’s second law, \( F = ma \), for a dynamic formulation (where is \( F \) the resultant external force vector and is \( a \) the acceleration vector of mass \( m \)), D’Alembert’s principle is invoked to use a static formulation of \( F - F_I = 0 \), where the inertia force magnitude is \( F_I = m r \omega^2 \) in the radial direction and/or \( m r \alpha \) in the tangential direction. In other words, we reverse the acceleration terms and treat it as a static problem. In Cosmos:

1. Right click on the **Part name**\( \rightarrow \)**Study, Name the part (spin_grid here), pick **Static** analysis, and for the **Model Type** pick thin shell mid-surface. (A planar model is almost always the cheapest and fastest way to do initial studies of a constant thickness part.)
2. When the **Study Menu** appears right click on **Shells**\( \rightarrow \)**Edit/Define Material.
3. In the **Material panel** pick **Library**\( \rightarrow \)**Steel\( \rightarrow \)**Cast Alloy.
4. Select **Units**\( \rightarrow \)**English. Note that the yield stress, SIGYLD, is about 35e3 psi (Figure 8). That material property will be compared to the von Mises Stress failure criterion later. (Property DENS is actually weight density, \( \gamma = \rho / g \), and is mislabeled.)

<table>
<thead>
<tr>
<th>Material name</th>
<th>CastAlloy Steel</th>
</tr>
</thead>
<tbody>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>EX</td>
<td>Elastic modulus</td>
</tr>
<tr>
<td>NUXXY</td>
<td>Poisson’s ratio</td>
</tr>
<tr>
<td>GXXY</td>
<td>Shear modulus</td>
</tr>
<tr>
<td>DENS</td>
<td>Mass density</td>
</tr>
<tr>
<td>SIGKXT</td>
<td>Tensile strength</td>
</tr>
<tr>
<td>SIGKXC</td>
<td>Compressive strength</td>
</tr>
<tr>
<td>SIGYLD</td>
<td>Yield strength</td>
</tr>
</tbody>
</table>

*Figure 8  Noting the ductile material yield stress*

**Displacement restraints**

For the centrifugal load due to the angular velocity only the spoke center plane and slots center plane always move in a radial direction. That means they have no tangential displacement (that is, no displacement normal to those two flat radial planes). In the CW_Manager:

1. Select **Restraints/Loads**\( \rightarrow \)**Restraints to activate the first **Restraint** panel.
2. Pick **On flat face** as the **Type** and select the part face in the 0 degree plane.
3. Set the **normal** displacement component to **zero** and **preview** the restraints, then hit **OK**. Repeat that process and select all seven of the part flat faces lying in the 36 degree plane (Figure 9).
At this point a total of eight surfaces are required to have only radial displacements. Either of the above two restraint operations eliminates a possible rigid body rotation about the axis of rotation. To prevent a rigid body translation of the part parallel to the axis you should also restrain the cylindrical shaft contact surface in that direction.

1. Select Restraints/Loads→Restraints to activate the first Restraint panel.
2. Type→On a cylindrical surface, select the inter-most cylindrical surface.
3. Displacement→Tangent to the surface centerline.

The radial displacement component on that surface is not restrained so as to allow the (small) motion away from the shaft due to the angular velocity. Optionally, you could restrain the displacement around the circumference to prevent the rigid body rotation, but the restraints in Figure 9 have already taken care of that.

**Angular velocity loading**

Next you set the centrifugal body force load due to the angular velocity. That will require picking the rotational axis so:

1. Select View→Axes
2. Right click Loads/Restraints→Centrifugal to activate the Centrifugal panel.
3. There pick Axis 1, set rpm (revolutions per minute) as the Units and type in 1000 for the angular velocity (while leaving the angular acceleration zero). That is summarized in Figure 10.
The radial acceleration, \( a_r = r \omega^2 \), varies linearly with distance from the axis, so expect the biggest loads to act on the outer rim. Also remember that the radial acceleration is also proportional to the square of the angular velocity. Thus, after this analysis if you want to reduce the stresses by a factor 4 you cut the angular velocity in half. (You would not have to repeat the analysis; just note the scaling in your written discussion. But you can re-run the study to make a pretty picture for the boss.)

![Figure 10 Invoking the centrifugal loadings](image)

**Mesh generation**

For this preliminary study each curved ring segment will act similar to straight fixed-fixed beam of the same length under a transverse gravity load. (To know about what your answers should be from Cosmos, do that simple beam theory hand calculation to estimate the relative deflection at the center as well as the center and end section stresses.) Thus, bending stresses may concentrate near the ends so make the mesh smaller there:

1. Right click **Mesh** \( \rightarrow \) **Apply Control** to activate the Mesh Control panel.
2. There pick the six bottom arcs as the **Selected Entities** and size ten elements there.
3. Then right click **Mesh** \( \rightarrow \) **Create**. The initial mesh (Figure 11) looks a little coarse, but okay for a first analysis.
4. Start the equation solver by right clicking on the study name and selecting **Run**. When completed review the study results.
Post-processing review

Both the displacements and stresses should always be checked for reasonableness. Sometimes the stresses depend only on the shape of the material. The deflections always depend on the material properties. Some tight tolerance mechanical designs (or building codes) place limits on the deflection values. CosmosWorks deflection values can be exported back to SolidWorks, along with the mesh model, so that an interference study can be done in SolidWorks.

Displacements

You should always see if the displacements look reasonable:

1. Double click on **Displacements**→**Plot 1** to see their default display, which is a continuous color contour format. Such a pretty picture is often handy to have in a report.
to the boss, but the author believes that more useful information is conveyed with the discrete band contours.

2. Right click on **Plot 1ÆEdit DefinitionÆFringeÆDiscrete**. Such default deformed shape displacement contours and undeformed (gray) shape are given in Figure 13 along with edits to display a vector format. Since displacements are vector quantities you convey the most accurate information with vector plots (Figure 13).

3. Right click in the graphics area; **Edit DefinitionÆDisplacement Plot Æ Display Æ Vector**.

4. When the vector plot appears dynamically control it with **Vector Plot Options** and increase **Size**. Then dynamically vary the **Density** (of nodes displayed) to see different various nodes and their vectors displayed. Retain the one or two plots that are most informative, such as in Figure 13.

![Figure 12 Default contours and edits for vector display](image1)

![Figure 13 Deformed shape and displacement vectors](image2)

As expected, the center of the outer-most rim has the largest displacement while the smallest displacement occurs along the radial “spoke” centered on the 0 degree plane. You may want to compare the relative displacement of the outer ring to a handbook approximation in order to validate the computed displacement results (and your knowledge of CosmosWorks). Localized information about the displacements at selected node or lines are also available for review:
1. Right click in the graphics area and select **Probe**. That lets you pick any set of nodes in the mesh and display their resultant displacement value and location (in gray) on the plot, as well as listing them in a table.

2. The probe operation is usually easier if you display the mesh first with **Edit Definition**→**Displacement Plot**→**Settings**→**Boundary Options**→**Mesh**. Using the support and center points in Figure 14 as probe points you find a relative displacement difference of about 2.01e-6 inches.

![Figure 14 Outer ring displacements at the center and support](image)

**Stress results**

All of the physical stress components are available for display, as well as various stress failure criteria. The proper choice of a failure criterion is material dependent, and it is the user’s responsibility to know which one is most valid for a particular material. The so called Effective Stress (actually distortional energy) value is often used for ductile materials.

**Effective stress**

The von Mises failure criterion (a scalar quantity) is superimposed on the deformed shape in Figure 15 using two formats: line contours, and discrete color contours. Also **Color Bar**→**Color Map** was used to select only eight colors. The maximum effective stress is only about 260 psi compared to a yield stress of about 35,000 psi. That is a ratio of about 134. Since the centrifugal load varies with the square of the angular velocity you would have to increase the current \( \omega \) by the square root of that ratio (about 11.5). In other words you should expect yielding to occur at \( \omega = 11.5 \) (1000 rpm) = 11,500 rpm.

Since this is a linear analysis problem, it would not be necessary to repeat the run with that new angular velocity. You could simply scale both the displacements and the stresses by the
appropriate constant. However, if you have a fast computer you may want to do so in order to include your most accurate plots in your written summary of the analysis.

Figure 15 The von Mises failure criterion and deformed shape

Principal stress

The magnitude and direction of the maximum principal stress is informative (and critical for brittle materials). Since they are vector quantities they give a good visual check of the directions of the stress flow, especially in planar studies (they can be quite messy in 3-D):

1. Right click in the graphics area, select Edit Description then pick P1 Maximum Principal Stress, and Vector style and view the whole mesh again.

2. If the arrows are too small (look like dots) zoom in where they seem biggest and further enhance your plot with a right click in the graphics area, select Vector Plot Options and increase the vector size, and reduce the percentage of nodes used for the vector plot. A typical P1 plot, with the deformed shape, is given in Figure 16.
Figure 16  Principal stress vector due to angular velocity

**Factor of safety**

For this material you would use the von Mises effective stress failure criterion. That is, your factor of safety is defined as the yield stress divided by the maximum effective stress. It was noted above that the ratio is greater than ten in this preliminary study.
Expected and computed results

A handbook solution for a fixed-fixed beam is given in Figure 17. To use these equations let the length be the arc length of the outer rib, \( l = r (\Delta \theta) = (3.81 \text{ in.})(72/57.3 \text{ rad}) = 4.79" \). The load per unit length is the product of mass density, \( \rho = \gamma/g \) with \( \gamma = 0.264 \text{ lb/in}^3 \), area \( A = h t = 0.0725 \text{ in}^2 \), and the centripetal acceleration (for \( \omega = 1000 \text{ rpm} = 104.72 \text{ rad/sec} \)), or \( w = \rho A r \omega^2 \). Here with \( \gamma = 0.264 \text{ lb/in}^3 \) and \( g = 386.4 \text{ in/sec}^2 \). Using the part material properties and geometrical data, \( w = (0.264 \text{ lb/in}^3)(0.0725 \text{ in}^2)(3.81 \text{ in.})(104.72 \text{ rad/sec})^2 \), so \( w = 2.07 \text{ lb/in} \), and the moment of inertia is \( I = t h^3 /12 = 0.2"(0.3625")^3/12 = 2.88e-4 \text{ in}^4 \). From the equations in the figure, the maximum displacement (at the 36 degree plane relative to the 0 degree plane) is \( \Delta_{\text{max}} = 3.26e-6 \text{ inches} \).

This approximate displacement is too far from the computed value (found with the Probe feature in Figure 14) of 2.04e-5 inches. You want to be within a factor of ten, at the most, to validate that you have the correct material (Modulus of Elasticity, \( E = 27.6e6 \text{ psi} \)). This would be an upper bound displacement since the full arc length was used, but the spoke has a thickness of about 0.25 inches. Thus, we could reduce the effective length to \( l = 4.24 \text{ inches} \). Since the beam theory deflection is proportional to \( l^4 \) the upper bound deflection estimate is \( \Delta_{\text{max}} = 3.26e-6 \text{ inches} \) \((4.24/4.79)^4 = 2.00e-5 \text{ inches} \), which is a very good agreement with the computed 2.04e-5 inches. (It is rare to get an estimate that agrees so well.)

The center moment is \( M_1 = w l^2/24 = 47.5 \text{ in-lb} \) (for the first length assumption, and 37.2 in-lb for the second length). The maximum center bending stress is \( \sigma_1 = M_1(h/2)/I = 2,062 \text{ psi} \) (in the part’s tangential direction), but the wall stress is twice that large (4,123 psi). This stress is in poor agreement with the computed value (found with the Probe feature in Figure 16) of about 260 psi.
Mesh revision
It now looks like a finer mesh is needed in the outer ring, but a coarser one could be used in the inner rings, for centrifugal loadings.

Angular acceleration model
The previous model considered only constant angular velocity, ω, so the angular acceleration was zero. During start and stop transitions both will present and the two effects can be superimposed because this is a linear analysis. Next consider the initial angular acceleration (where ω = 0 for an instant). You can always use the full model, but that takes a lot of computer resources. The most correct symmetric analysis would require using any 72 degree segment and invoking a special restraint know as multiple point constraints or repeated freedoms for nodes on those to edges. That means we know the two edges have the same displacement components normal and tangential to the edges, but they are still unknowns. Rather than doing that you can get an accurate approximation by assuming that the Poisson ratio effects can be neglected. Then symmetry planes of the model will have no radial displacement, just tangential displacement due to the tangential acceleration (rα). Apply that approach with the previous 36 degree segment with to symmetry planes. Remember to prevent the rigid body motions of rotation about the axis and translation along the axis.

Restraints
First apply zero radial displacement on the two symmetry planes from the CWManager via Loads/Restraints→Restraints as illustrated in Figure 18. To prevent the two rigid body rotations select the inner cylindrical surface and impose displacement restraints in the axial dimension, and around the circumference, as shown in Figure 19.
Angular acceleration Loads

You need to identify the axis and angular acceleration value. Pick View→Axes. Then select Loads/Restraints→Centrifugal and pick Axis 1 in the Centrifugal panel and type in the value of the angular acceleration (Figure 20).
**Mesh and solution**

Here you can simply use the same meshing process given in Figure 11. That creates slightly less than 9,000 equations to solve for the two displacement components at each node.

**Post-processing**

**Displacements**

The displacements, of Figure 21, are mainly in the tangential direction (relative to the undeformed shape in light gray) as seen by the contour values and displacement vectors. Using the right click **Probe** the maximum displacement at the spoke was seen to be 2.1e-5 inches in the bottom table (and light gray in the middle).

![Figure 21 Maximum displacements from a vector plot and node probe](image-url)
Stress results

The effective stresses (Figure 22) are quite low, for the current angular acceleration value. Increasing the angular acceleration by a factor of 500 would put the stress at about 34,000 psi, which is just below the yield point. The maximum stresses occur around the innermost slot. Figure 23 shows that the maximum tension occurs on the lower right edge of the first groove. Both the maximum compression and shear occur in the lower left (red) regions of Figure 22.

You should expect the maximum shear to occur there. The (reaction) torque necessary to accomplish the specified angular acceleration is transmitted radially by the spokes. The ribs can be viewed as similar to lumped masses attached to a cantilever spoke. As you move from the outer rib toward the rotation axis you are picking up more mass, and you get the maximum torque by the inner hole. That torque is transmitted by shear stresses here. The first open gap has the largest torque going through the spoke thickness.
Full part model

If you failed to recognize the above symmetry cases and/or if you have both large angular velocity and angular acceleration acting at the same time (like braking from the maximum rotational speed) then you might be forced to employ a full part model. To do that you must first build the full part.

Building the part

Return to the 36 degree segment geometry model. The full model geometry can be built from various mirrored and repeated uses of that segment. Open the segment geometry:

1. Select Insert→Pattern/Mirror→Mirror. Pick the original Body.
2. Chose any of the rib end faces as the Mirror Face, and Merge the two parts (Figure 24). That creates a 72 degree segment, in Figure 25.

![Figure 24 Mirroring the 36 degree segment](image)

Five copies of the last geometry yield the full model. Construct them with a circular pattern copy:

1. Insert→Pattern/Mirror→Circular Pattern.
2. In the Circular Pattern panel, pick the new 72 degree segment as the Body to Pattern, preview the result and hit OK to accept, as shown in Figure 26. While this result may look okay, it is actually five independent parts (note the part lines every 72 degrees) and CosmosWorks will not accept it for analysis. They are combined by a Boolean union.
3. Use Insert→Features→Combine to bring up the Combine panel of Figure 27. There the Boolean union Operation Type is named Add, and under Bodies to Combine you must select each of the five parts and hit OK. Then the part lines vanish (Figure 28) and you can now conduct an analysis in CosmosWorks.
Figure 25  Prepare to pattern the 72 degree segment

Figure 26  Five part copies of a typical segment part

Figure 27  Combining (Boolean union) the five parts
**Begin CosmosWorks study**

In the CWManager right click on the name and select **Study**, assign a name, select **Static** analysis, and use a **mid-surface shell** mesh, as in Figure 28. Use the same material properties as above.

![Figure 28 Beginning the angular acceleration load study](image)

**Mesh generation**

**Split the surface**

A full part model can require huge computer resources. You need to exercise care when generating the mesh. From the above preliminary studies (or engineering judgment) you only need a fine mesh in 36 degree segment, or the outer ring of that segment. To hold down the resources you should build a fine mesh in only one segment and specify large elements in the remaining 4/5 of the part. To do that you need to insert split lines to cut the front into a small and a large surface for assigning different element sizes.

1. Draw a radial straight line crossing over the 0 degree rib. Right click on the front face **Insert Sketch, Insert** → **Curve** → **Split Line** (Figure 30).
2. In the **Split line panel** use a **Projection Type of Split**. Repeat at the 72 degree spoke. When done you should see two lines creating the 1/5 and 4/5 surfaces as in Figure 31.

**Controlling the mesh**

As noted above, you need a fine mesh only in one 72 degree segment (and maybe just in a 36 degree segment). In the CWManager:

1. Right click on **Mesh** → **Apply Control** to activate the **Mesh Control panel**.
2. Note the default element size. Then pick the 1/5 region surface as the **Selected Entities** and change the element size to be smaller (0.02 inch here).
3. Next repeat the process for the larger surface area and use a much bigger element size (0.2 here), as shown in Figure 31.
4. Right click **Mesh** → **Create** to build the mesh (this will take some time).
Figure 29  Prepare to split the front face

Figure 30  Building and applying the split lines

Figure 31  Select fine and course mesh regions
In this case the resulting mesh, Figure 32, includes almost 100,000 displacement components to compute (so you may run out of disk space). Note the transition region from the crude spoke mesh to the fine one.

![Figure 32 Resulting mesh transitions](image)

**Restraints**

To eliminate the rigid body motion, along and about the axis:

1. Right click **Loads/Restraints**→**Restraints** to get the **Restraints panel**.
2. Select the cylindrical hole surface, set **Type** to **On cylindrical face**
3. Set the axial and circumferential displacement components to zero (Figure 33 left). Since this is a quite large problem, it is wise to turn off the shell degrees of freedom (dof) that are zero (so they don’t get computed).
4. Pick the front face and set its normal displacement to zero, as well as the two inplane rotational components.

**Angular acceleration loading**

As before, you just need to identify the axis and angular acceleration value:

1. Pick **View**→**Axes**.
2. Then right click **Loads/Restraints**→**Centrifugal**
3. Pick **Axis 1** in the **Centrifugal panel** and type in the value of the acceleration (Figure 34). The direction of the angular acceleration vector is highlighted by a red arrow (according to the “right hand rule”). Next proceed to the solution.
Solution process

Even with this crude mesh over 4/5 of the part it has about 100,000 displacement components to compute. The results are summarized below. You will see that they compare well to the above approximations.
Post-processing

Displacements

For the default displacement contour plot:

1. **Displacements→Plot1.** The displacement results are basically cyclically repeated every 72 degrees, as expected. The differences are due to the varying crudeness of the mesh that was used to reduce the computational effort.

2. To see the displacement vectors right click in the graphics area to **Edit Definition**.

3. In the **Edit panel** select the vertical component (**UY**), **Vector**, and **Line, OK**. Also open **Vector Plot Options** to vary the arrow size and the percent of nodes displayed (while looking at the display).

Looking along the 0 degree line you see the displacement is mainly in the tangential (Y) direction and that the radial (X) displacement is basically zero (Figure 35), as assumed in 36 degree segment approximation. The contour of zero radial displacement (green line in Figure 36) continues through the coarse mesh region. That validates the assumptions used in the 36 degree model.

![Figure 35  Total, Y, and X displacements](image)
Stress results

The angular acceleration stress results are quite low, as before, and occur mainly around the innermost gap ends (Figure 37). That is to be expected since the angular acceleration of the outer mass (rings) causes the biggest shear stress in the first spoke segment.

Closure

These three studies show that you can often pick symmetry regions in rotational loadings and drastically reduce the computer resources required. Here it seems like you could refine the outer spoke mesh further to see angular velocity effects and refine the innermost gap ends to see the worst angular acceleration effects.

Actually, the full model could have been replaced by the 72 degree segment in Figure 25 by using a cyclic symmetry boundary condition. However, CosmosWorks does not currently offer that commonly needed case.
Figure 37 The von Mises failure criterion in the full part

References