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Chapter Overview 

In this chapter we introduce the basic features in Mechanical : 

A. Basic Analysis Procedure 

B. The Mechanical Interface  

C. Menus 

D. Toolbars 

E. Outline Tree and Details 

F. Graphics Window 

G. Scoping Loads and Supports 

H. Demonstration 

I. The Engineering Data application 

J. Assigning Material Properties 

K. Demonstration 

L. Workshop 2-1 

M. Appendix 
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A. Basic Analysis Procedure 
A finite element analysis is used to determine the response of a system based on some type of 
loading. 

It is important to remember that a finite element solution is an approximation: 

• CAD geometry is an idealization of the physical model. 

• The mesh is a combination of discrete “elements” representing the geometry. 

• The accuracy of answers is determined by various factors, one of which is the mesh density. 

CAD Model Finite Element Mesh 
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… Basic Analysis Procedure 

An analysis can be described in the context of four main steps: 

• Preliminary Decisions 

– What type of analysis: Static, modal, etc.? 

– What to model: Part or Assembly? 

– Which elements: Surface or Solid Bodies? 

– Should I start with a simpler model? 

– Symmetry? 

• Preprocessing 

– Attach the model geometry 

– Define and assign material properties to parts 

– Mesh the geometry 

– Apply loads and supports 

– Request results 

• Solve the Model 

• Postprocessing 

– Review results 

– Check the validity of the solution 
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B. The Mechanical Interface 
The components of the user interface are shown below: 

Outline Tree 

Details View 

Graphics Window 

Toolbars 
Menus 

Mechanical 

Application Wizard 

Status Bar 
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A range of menus and toolbars provide much of the general functionality in Mechanical. 

• The title bar lists analysis type, product and active ANSYS license. 

 

 

 

Some menu and toolbar items are self explanatory.  We’ll cover the basic controls on the next few slides. 

• Additional controls and features will be introduced throughout the course as they are encountered. 

Note: the windows in Workbench and the Mechanical application can be customized.  If you wish to return to a 
default layout use in either: 

Mechanical:  “View > Windows > Layout > Reset Window Layout”. 

Workbench: “View > Reset Window Layout”. 

. . . The Mechanical Interface 



7 © 2015 ANSYS, Inc. February 27, 2015 

The “Standard” toolbar is shown below (details will be covered later): 

 

 

 

 

A. Activate the Mechanical Wizard. 

B. Object Generator. 

C. Solve. 

D. Populate the message windows with the appropriate error message for any tree objects that are not 
properly defined. 

E. Create slice planes, annotations, charts and tables. 

F. Add comments and figures to the tree. 

G. Activate optional Worksheet view. 

H. Activate selection information window. 

 

D. Toolbars 

F E D C B A G H 
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The Context toolbar updates depending on current tree selection. 

 

 

 

 

 

• Context sensitive features are exposed as different branches are highlighted. 

• In almost all cases an alternate path to these features is available by right clicking 
(RMB), when the branch is highlighted. 

. . . Toolbars 
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The Graphics toolbar graphical selection section: 

Select Geometry (vertex, face, etc.): 

• Use single or box select modes. 

Select Mesh (nodes): 

• Use single or box select mode (including box, box 
volume and lasso volume). 

• Select mesh is only available when the mesh is 
displayed. 

 

 

 

 

Filters 

Box Lasso 

Volume Select 

. . . Toolbars 
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Selection planes allow for users to easily select entities that 
are overlaying one another. 

• An initial selection point acts as the starting point for a  path 
through the model. 

• Each entity encountered is displayed by a selection plane. 

• The path through the model is in the normal Z (viewing) 
direction. 

 

 

 

• Example using surfaces: initial selection location. 

 

. . . Toolbars 
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The Graphics toolbar graphical manipulation section (left mouse button): 

A. Common features (rotate, pan, zoom, box zoom) are to the left of the toolbar. 

B. A “fit” button and magnifier window toggle are available. 

C. When zooming, a “stack” is stored and can be retraced using previous or next buttons. 

D. Isometric view. 

E. “Look At” selected entities, reorients view normal to current selection. 

F. Manage Views. 

G. Resize annotations on loads and supports after zooming. 

H. Tags. 

B A C D E F G H 

. . . Toolbars 
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E. Outline Tree and Details 

The Outline Tree branches represent various operations. Each 
branch has an associated status symbol. 

• Becoming familiar with the status symbols will allow you to 
debug Mechanical problems quickly. 

 

 

Solution Branch Icons 
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… Outline Tree and Details 

The Details View contains input and output fields (the contents will change depending on the branch 
selected): 

• White field: input data that can be edited. 

• Yellow field: incomplete input data. 

• Gray field: information only, cannot be modified.  

• Red field: Result no longer up to date (must re-solve). 

 



14 © 2015 ANSYS, Inc. February 27, 2015 

As said before, becoming familiar with the status symbols will allow you to debug Mechanical 
problems quickly. To help you in this task, you can use the “Show Errors” button. 

… Outline Tree and Details 
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F. Graphics Window 
The Graphics Window shows the geometry and results. Tabs allow access to Print and Report 
Previews as well. 
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… Graphics Window 
Worksheet views are available for many objects in the tree (i.e. geometry, connections, etc.). 

Provides a list view of the data in the tree. 

Activate 

Worksheet 

Toggle between 

graphics and 

worksheet 
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Keyboard Shortcuts are supported in Mechanical for common 
actions such as: Select All Objects (Ctrl+ A), Body Filter 
Selection (Ctrl+B), Zoom to Fit (F7). 

… Graphics Window 
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G. Scoping Loads & Supports 

Loads and supports can be applied as: 
1. Scope, then action (pre-select): 

– Select geometry entity in Graphics Window, then select load or support (context 
toolbar or RMB > insert). 

– Define magnitude and direction (if required). 

OR 

 
2. Action, then scope: 

– Select load or support from the context menu or RMB > Insert. 

– Select the scope, then “Apply” in the details. 

– Define magnitude and direction (if required). 

Notes: 

• Preselecting (1) is more efficient since it avoids having to use the Apply/Cancel function (pre-
selection is automatically “applied”). 

• If you wish to change a boundary condition’s location simply click in the geometry field to bring 
up the Apply/Cancel selections and make a new selection. 
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Some loads require a direction. There are 2 methods of direction control: 

Component Method: 

• In the details view set “Define By” to “Components”. 

• Select the desired coordinate system (local or global). 

• Enter X, Y, and Z magnitudes. 

 

… Scoping Loads & Supports 
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… Scoping Loads & Supports 

Vector Method: 

– In the details view set “Define By: to “Vector”. 

– Enter the load magnitude. 

– Click the “Direction” field and choose the control geometry (vertex 
pairs, edges or surfaces). 

– “Apply” to confirm. 

• To modify directions using the vector method: 

– Click in the “Direction” field and select new control geometry. 

– Use the arrows in the Graphics window to reverse directions.   

– “Apply” when finished. 

Default method can be set in: “Tools > Options …  
> Mechanical: Miscellaneous> Load Orientation Type”. 

 

 
Note: structural simulations allow certain boundary conditions to be applied directly to the finite element nodes. 
The technique is covered in lecture 5. 

Toggle arrow buttons to reverse 

load direction 
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H .Demonstration 

Demonstration : 02_Mechanical_Intro.mp4 
 

• What you can learn in this demonstration : 

 

– Mechanical Interface presentation 

– Details on graphical window 

– How to manipulate a model 

– Toolbar description 

– Outline Tree branches description 

– Use the Details window 

– Scoping loads and supports 
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I. The Engineering Data Application 
The Engineering Data application provides control for material properties. 

• Engineering Data can be opened “stand alone” or from the analysis system cell (double click or RMB>Edit). 

 

 

 

 

 

 

• Note : A Physics Filter toggles between displaying all materials and properties or only materials relevant to the 
analysis systems in the project  

 

• A key concept in Engineering Data is that materials must be checked out of a material library and into a project 
before they can be used in your analysis 

 

 

 

 

Data Source (Material Library) Workbench Project 



23 © 2015 ANSYS, Inc. February 27, 2015 

. . . The Engineering Data Application 

Project View 

Materials available in current analysis 

IMPORTANT!: Only materials shown in the Project view will be available in the 
analysis. 
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. . . The Engineering Data Application 

Users can define their own material or use one from the « Engineering data source » 
 
 
To use « Engineering data source », click on  

Highlight the desired library 

Click the “+” next to the desired 
material 

Note : users can check 
material properties before 
import in the project view 
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. . . The Engineering Data Application 
To create a new material: 

• Toggle to the project materials display. 

• Enter a name for the new material. 

• From the Toolbox double click or 
drag and drop the desired 
properties. 

 

• Enter values for the properties. 

 

• Note: properties can be added to 
existing materials using the same 
technique. 

= OFF 
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. . . The Engineering Data Application 

To place a new material in a library you must export it as an xml 
file first. 

• Highlight the material name 

• From the “File” menu choose “Export Engineering Data”. 

• Browse to the desired location to store the file. 

Continued . . .  
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. . . The Engineering Data Application 

Toggle to the “Data Sources” display. 

 

• Highlight the material library where the new material is 
to be stored. 

• The material library must be unlocked (edit mode) before 
new materials can be added. 

 

• From the “File” menu choose to “Import Engineering 
Data”. 

• Browse to the xml file for the new material. 

= ON 
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. . . The Engineering Data Application 

• To create a material library toggle to the Data Sources display. 

 

• Enter a name and select a location (a browser will open automatically). 

Engineering Data files (libraries and materials) are stored in .xml format. 

= ON 
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J. Assigning Material Properties 

• Material properties are assigned to parts in the “Material Assignment” field in the 
part’s details (Mechanical application). 

• Notice there are several shortcuts allowing quick access to the Engineering Data 
application in Workbench.  

Materials already selected in 
Engineering Data 

Jump to Engineering Data to define 
new material or import from 
library. 

Jump to Engineering Data to edit 
the current material selection. 
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K. Demonstration Video 

Demonstration : 03_Engineering_Data.mp4 
 

• What you can learn in this demonstration : 

 

– Define new material and edit properties 

– Export / Import created materials 

– Use Ansys material library 

– Assign material properties to parts 
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• Workshop 2.1 – Mechanical Basics 

• Goal: 

– Using the Stress Wizard, set up and solve a structural model for stress, 
deflection and safety factor. 

L. Workshop 2-1 – Mechanical Basics 
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M. APPENDIX 
 

• Menus 
• Graphics Control and Selection 
• Tagging and tree filtering 
• Grouping tree object 
• The Mechanical application wizard 
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The View menu: 

• Control basic graphics (shaded, wireframe, etc.). 

 

• Control graphical expansion of shells and beams. 

 

• Control display utilities (legend, triad, ruler, etc.). 

 

• Set preferences for annotation display. 

 

• Select the desired toolbars and windows to be displayed. 

Menus 
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The Units menu: 

• Specify the unit system for Mechanical. 

• Note, Mechanical may use any unit system regardless of the 
one specified in Workbench.  Where needed, automatic 
conversions will be made. 

• Mechanical will “remember” the units used in the previous 
session (regardless of the units set in Workbench).  

 

 

 

• Specify additional units for angular, rotational and thermal 
references. 

. . . Menus 
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Annotation Preferences: 

• Controls the display of 
annotations for loads/constraints, 
user labels, remote conditions 
and meshing displays. 

 

• Make preference selections then 
“Apply” or “OK” to reflect the 
changes. 

 

. . . Menus 
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Graphics Control and Selection 

Graphics Shortcuts: 

• Middle Mouse button (wheel): 
• Free rotation 

• + CTRL = panning 

• + Shift = zoom 

• Right Mouse Button: 
• Scroll mouse wheel to zoom in/out 

• Hold RMB + drag = box zoom 

RMB Context Menu from graphics window: 

• Access isometric view controls and fit. 

• Standard views built in.  

Click the axes of the triad to reorient view. 
• Click the blue “iso” ball for isometric view. 

LMB RMB 
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… Graphics Control and Selection 

Graphics Options toolbar: 

A. Show Vertices: Accentuates vertex display for easier identification. 

B. Wireframe: Toggles view (solid/wireframe). 

C. Show Mesh: Show mesh instead of geometry. 

D. Show all coordinate systems. 

E. Random Colors: Use random Colors for load and name selection annotations 

F. Annotation Preferences: explain in the next slide 

 

 B A C D E F 
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… Graphics Control and Selection 

Graphics Options toolbar: 

A. Edge Controls:  Edge color control and display options based on edge connectivity 
(number of faces connected to an edge). 

B. Show edge direction. 

C. Show edges where mesh connections are used. 

D. Thicken line display where lines have boundary conditions scoped. 

B A C D 
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Tagging and Tree Filtering 

The Tree Filter: 

• To streamline the management of tree objects, especially 
for large models, a tree filter can be used to find objects or 
to reduce the length of the tree that is displayed. 

• Filter by: Name, Tag (discussed later), Type or State. 

• Examples: 

 

 

Filter by state = underdefined to 
find only those objects in the tree. Filter by type = results to only 

display result items. 
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… Tagging and Tree Filtering 

The Tree Filter Example: 

• Filter Name = “shaft” (user entry) 

• Notice here there are a number of branches 
containing the word “shaft”.  By using the tree filter 
each can be quickly found. 
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… Tagging and Tree Filtering 

Tags are designations that can be assigned to any branch in the tree and used with the previously 
discussed filtering capability. 

• Activate the tags window from the “View” menu or the Tags icon. 

 

With the tags view active, a new 
“tags” window is displayed below the 

details window 
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… Tagging and Tree Filtering 

Creating Tags: 

• From the Tags window choose to “Add a Tag”. 

• Enter a name for the new Tag in the dialog box. 

 

 

• With tags created, add items by highlighting in the 
tree and checking the box by the tag. 

 

 

Note : the item selection for tags can only be performed from 
the tree and not from the graphic interface. 

 

 

 

Highlight Items 
and Check Tag 
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… Tagging and Tree Filtering 

Tags Summary: 

• Any object branch in the tree can be tagged. 

• Objects can be associated with more than one tag. 

• Manage tags from the tags window. 

• Highlight Tags and RMB to find items. 

Find objects in a single tag Find objects in multiple tags 
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Grouping Tree Object 

For the following object types, Mechanical enables you to organize 
and group together like-objects : 

• Geometry 
• Coordinate System 
• Connection features: Springs, Beam Connections, End 

Release, and Bearings 
• Named Selections (Named Selections within 

the Fracture folder cannot be grouped.) 
• Boundary conditions 
• Results (child objects of the Solution folder) 
 

For boundary conditions and results, 
the Group Similar Objects groups together objects of the same type 
(e.g., Pressure, Displacement, etc.) and renames the group folder 
according to that type 
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The Mechanical Application Wizard 
The Mechanical Wizard is a useful aid in guiding users in locating 
the features required to complete an analysis: 

• Provides a list of required tasks based on the wizard type (e.g. 
structural, thermal, etc.).  

• Icons indicate the status of each task (similar to tree status symbols). 

By selecting an item on the “Required Steps” checklist, a callout 
appears, illustrating where that task is performed. 

 


