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NWNYSHE Goals

Workshop 7.1 consists of a 5 part assembly representing an impeller type pump. Our
primary goals are to analyze the assembly with a load on the belt of 100N to test:

* That the impeller will not deflect more than 0.075mm with the applied load.

* That the use of a plastic pump housing will not exceed the material’s elastic limits around the shaft
bore.
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AW NYEH Assumptions

3

We’ll assume the pump housing is rigidly mounted to the rest of the pump assembly. To
simulate this, a frictionless support is applied to the mounting face.

Similarly, frictionless surfaces on the mounting hole counter bores will be used to
simulate the mounting bolt contacts. (Note if accurate stresses were desired at the
mounting holes, a “compression only” support would be a better choice).

Finally, a bearing load (X = 100 N) is used on the pulley to simulate the load from the
drive belt. The bearing load will distribute the force over the face of the pulley only
where the belt contact occurs.
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Project Schematic
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WSS Preprocessing

4. On the toolbar within the ANSYS Mechanical environment, select Units, and change the

system’s unit to
® Metric (mm, kg, N, s, mV, mA)

® (Note — material data is not being checked but it is good practice to confirm units)

5c.
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5. Add “Polyethylene” the Engineering Data (return to Workbench window):
a. Double click the Engineering Data cell.
b. Activate the Engineering Data Sources toggle and highlight General Materials and click the + sign
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WNYEH . . . Preprocessing

6. Refresh the Model cell:
a. RMB > Refresh.

Return to the Mechanical window.

7. Change the material on the pump

housing:
a. Highlight “PumpHousing” under
geometry.

b. From details change the material
assignment to “Polyethylene”.
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WSS . . . Preprocessing

8. Change the contact region behavior for one of the

contact regions (shown below): a---«ga fﬂ”?ﬂ;ﬁis
a. Hold the shift key and highlight all the contacts, and | 2. Bonded - PumpHiousing To Impeler
RMB>Rename Based on Definition. L______: a Separaﬁfge (FLITET I e
" . -, B, Bonded - Impeller To Nut
b. From the detail window change the contact type to “no |~ Bonded - Puley To Shaft

- B, Bonded - Shaft To Nut

separation” for the contact PumpHousing to Shaft

e The remainder of the contacts will be left as “bonded”
(all default contact condition is set to bonded).

Separation - PumpHousing To Shaft
04/12/2014 16:47

[ Mo Separation - PumpHausing To Shaft
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\WNYEHE Environment

9. Apply the bearing load to the pulley:
a. Highlight the “Static Structural” branch.
b. Highlight the pulley’s groove surface.
C. RMB > Insert > Bearing Load”.

d. From the detail window change to “Components” and “X = 100 N”
m ? A: Static Structural

| Fitter:  name = o e Bearing Load
Project 11
=] Model (A4) 04/12/2014 16:47

- Geometry
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NLWNYEHE . . . Environment

10. Apply supports to the assembly:

a. Highlight the mating face on the pump housing (part 1).
b. “RMB > Insert > Frictionless Support”.

9
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NWWNSYSH . . . Environment

Now we will add the frictionless supports to the 8 countersink portions of the mounting
holes (shown here).

Each of the required surfaces could be selected individually while holding the CTRL key.

However, this could be accomplished more swiftly with the use of either Named Selections
or macro
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NUWNEHN . . . Environment

11. Select any one of the countersunk holes:

11

a. RMB, choose “Create Named Selection”.

b. Under “Apply geometry items of same”, check box for “size”
C. Click “ok”

d. RMB on Static Structural and insert a Frictionless Support

€. In the details window switch “Scoping Method” to Named
Selection

f. Under “Named Selection” switch to “Selection”

¥ o

11f. | "=
. Scoping Method | Named Selection
Selection -
=| Definition
ID (Beta) 67
Type Frictionless Support

Suppressed i [e]

If the user used this approach, go directly to step 13 (slide 14).
Alternative, if the user decides to take the macro approach,
continue to the next slide.
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NWSYEN . . . Environment (Alternatively)

11. Rather than using Named Selections, the selection can be
accomplished by size macro:

a. Highlight 1 of the countersink surfaces (arbitrary).
b. Choose “Tools > Run Macro . . .” and browse to:

C:\Program Files\ANSYS Inc\v160\aisol\DesignSpace\DSPages\macros

C. Inthe browser choose “selectBySize.js”
d. Click “Open”
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IAWNYSE . . . Environment

Constrain the countersunk hole surfaces:

12. From the context menu, click on “Supports” and choose “Frictionless Support” or “RMB >
Insert > Frictionless Support”

A: Static Structural
Frictionless Support 2
Time: L s
04/12/2014 16:56

. Frictionless Support 2
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IAWSYEH Solution

13. Highlight the “Analysis Settings” and from the details
window change “Weak Springs” from “Program Controlled”
to “Off”. 13.

e AT FrICTIONIESS SUPPOrT
e SEL Frictionless Support 2

=188 Solution (A6)

= 11

==
Step Controls

L ey

Note : Because of the presence of frictionless supports and B R oo tormation
non bonded contact, Workbench-Mechanical will trigger ST —

the use of weak springs during the solution. If we know the % b comoss

model is fully constrained we can turn off this function. [ A— |

14. Solve the model:

® Choose solve from the tool bar or RMB Solution branch and
choose “Solve”.
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WNYEH Postprocessing

15. Add results to solution:
a. Highlight the solution branch:

b. From the context menu, choose Stress > Equivalent (von-Mises) or RMB > Insert > Stress >
Equivalent (von-Mises)

C. Repeat the step above, choose Deformation > “Total Deformation”

* Solve again.

* Note: adding results and re-solving the model will not cause a complete solution to take
place. Requesting new results requires only a re-read of the results file.

* Alternatively, the requested results can be process by RMB on Solutions and pick Evaluate All
Results options

ANSYS Multiphysics]

- ALl Aol L= i
= SEnerae > S Damans = |
%, Equivalent (von-Mises)
" @, Maximum Principal
. Middle Principal
2. Minimum Principal

&, vector Principal
. Error

. Membrane Stress
%2, Bending Stress

1 €4 Bottom Peak Stress (Beta)
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WIS . . . Postprocessing

While the overall plots can be used as a reality check to verify our loads, the plots are less
than ideal since much of the model is displayed in few colors. (your results may vary
slightly due to meshing differences).

A: Static Structural
Equivalent Stress
Type: Equivalent fvon-Mises) Stress

A: Static Structural
Total Deformation
Type: Total Deformation

Unit: rarm U.nit: hPa
Tirme: 1 Tirne: 1
014/12/2014 16:44 04/12/2014 15:43
1.7926 Max
0.036398 Max L5934
0.032358 L3042
0023318 L1105
0024278 0.09587
0020237 0.796649
0.0La187 0.59752
0012157 0,39835
0.0081164 0,19917
00040762 1.4367e-8 Min
3.2863e-3 Min
H H : HITRU ” H H ”
To improve the quality of results available we will “scope” results to individual parts”.

16 © 2015 ANSYS, Inc. September 15, 2015



I\WNYEN . . . Postprocessing

16. Scope the results to individual bodies/surfaces:

a. Highlight the “Solution” branch and switch the selection
filter to “Body” select mode.

b. Select the impeller (part 2)
C. “RMB > Insert > Stress > equivalent (von- Mises)”

®* Notice the detail for the new result indicates a scope of
1 Body.

®* Now the local variation in the results are more visually
distinct.

17. Repeat the procedure above to insert “Total
Deformation” results for the impeller part.

18. Repeat to add individually scoped stress and total
deformation results to the pump housing (part 1).
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A: Static Structural
Total Deformation 2
Type: Total Deformation
Unit: rrn

Time: 1
04/12/2014 16:59

0.022487 Max
0.019988
0017434

0.015

0.012506
0.010012
0.007518
0.0050239
0.0025299
3.5863e-5 Min




ALSEH . . . Postprocessing

19. To give physically meaningful names to the result objects, it is useful to
rename the new results:

a. Highlight all results > RMB > Rename Based on Definition. The result objects should
now contain more informative names

20. Evaluate All Results

-5 Solution (AG)
41 Solution Information
19 A Total Deformation
AEm Equivalent (von-Mises) Stress
Afm Total Deformation - Impeller
Am Total Deformation - PumpHousing
AEE Equivalent (von-Mises) Stress - PumpHousing
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WWNYEH . . . Postprocessing

By checking the impeller deformation we can verify that one of our goals is met. The
maximum deformation is approximately 0.028mm (goal < 0.075mm).

A: Static Structural
Total Deformation 2
Type: Total Deformation
IInit: mim

Tirne: 1

n4/1272014 16:59

. 0.022482 Max
0.019983

— 0.017494

— 0.015

= 0.012506

— n.o10012

— 0.007518

0.0050233
I 00025298
3.5863e-5 Min
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IWWNSYEH . . . Postprocessing

Inspection of the housing stress shows that, overall, the stress levels are below the
material’s elastic limit (tensile yield = 25 MPa). We could again use scoping to isolate the
results in the area of interest.

A: Static Structural
Equivalent Stress 3
Type: Equivalent (von-Mises) Stress
Unit: MPa

Time: 1
04712/2014 17:01

0.93251 Max
0.82901
0.72552
0.62202
0.51853
0.41503
031154

—{ 0.20804

| 0.10455
0.0010501 Min
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NLWNYSE Examining stress results

The stress results are often not as “smooth” as the deformation results, this is due to the
fact that the displacement field is continuous across the nodes whereas the stress is not.
Therefore the stress results can “fluctuate”.

By default ANSYS takes the averaged stress result to reduce the “fluctuation”

Averaged

A: Static Structural
Equivalent Stress 3
Type: Equivalent (von-Mises) Stress
Unit: MPa

Time: 1
04/12/2014 17:03

0.93251 Max
0.82901

0.72552

0.62202

051853

0.41503

0.31154
0.20804

0.10455
0.0010501 Min
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VS

Details of "Equivalent Stress”

+|Scope

+ | Definition
Display Option Averaged
Average Across Bodies |No

+| Results

+ Information

Un-averaged

A: Static Structural
Equivalent Stress 4
Type: Equivalent (von-Mises) Stress
Unit: MPa

Time: 1
04/12/2014 17:04

0.96277 Max
0.85593

0.7491

0.64227

0.53543

0.4286

032177

0.21494

0.1081
0.0012714 Min



WWNSYER Go further!

The Mesh of the bodies is very coarse...
In order to get more physical results, the user must change the mesh.

Here’s a suggestion of mesh:
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. . . Go further!

The user can nhow re-examine the results:

A: Static Structural
Total Deformation 2
Type: Total Defarmation
nit: mim

Tirme: 1

nas1a2014 1112

. 0.029408 Max
0.026144

— 0.022a8

— 0.019616

= 0.016352

— 0.0130848

— 0.0093238

0.0065597
I 0.0032957
3.1601e-5 Min
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. . . Go further!

A: Static Structural

Equivalent Stress 5

Type! Equivalent (ron-hdises) Stress
Unit: bAPa

Tirme: 1

047122014 11115

0.81616 Max

0.73499

065381

057264

049147

0.41023 A: Static Structural

032912 Equivalent Stress 6

0.24794 Type: Equivalent (won-Mises) Stress (Unaveraged)
016677 Unit: kPa

0.085596 Min Time: 1

04/12/2014 17:16

0.81788 Max
0.73634
0.6548
057327
0.43173
0.41019
0.32866
0.24712
016558
0.084048 Min
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